Merge branch 'collectd-3.11'
[collectd.git] / contrib / fedora / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        3.11.2
4 Release:        0.fc0
5 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
6 License:        GPL
7 Group:          System Environment/Daemons
8 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9 BuildPrereq:    lm_sensors-devel, mysql-devel, rrdtool-devel
10 Requires:       rrdtool
11 Packager:       Florian octo Forster <octo@verplant.org>
12 Vendor:         Florian octo Forster <octo@verplant.org>
13
14 %description
15 collectd is a small daemon written in C for performance.  It reads various
16 system  statistics  and updates  RRD files,  creating  them if neccessary.
17 Since the daemon doesn't need to startup every time it wants to update the
18 files it's very fast and easy on the system. Also, the statistics are very
19 fine grained since the files are updated every 10 seconds.
20
21 %package apache
22 Summary:        apache-plugin for collectd.
23 Group:          System Environment/Daemons
24 Requires:       collectd = %{version}, libcurl3
25 %description apache
26 This plugin collectd data provided by Apache's `mod_status'.
27
28 #%package email
29 #Summary:       email-plugin for collectd.
30 #Group:         System Environment/Daemons
31 #Requires:      collectd = %{version}, spamassassin
32 #%description email
33 #This plugin collectd data provided by spamassassin.
34
35 %package mysql
36 Summary:        mysql-module for collectd.
37 Group:          System Environment/Daemons
38 Requires:       collectd = %{version}, mysql
39 %description mysql
40 MySQL  querying  plugin.  This plugins  provides data of  issued commands,
41 called handlers and database traffic.
42
43 %package sensors
44 Summary:        libsensors-module for collectd.
45 Group:          System Environment/Daemons
46 Requires:       collectd = %{version}, lm_sensors
47 %description sensors
48 This  plugin  for  collectd  provides  querying  of sensors  supported  by
49 lm_sensors.
50
51 %prep
52 rm -rf $RPM_BUILD_ROOT
53 %setup
54
55 %build
56 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir}
57 make
58
59 %install
60 make install DESTDIR=$RPM_BUILD_ROOT
61 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
62 mkdir -p $RPM_BUILD_ROOT/var/www/cgi-bin
63 cp src/collectd.conf $RPM_BUILD_ROOT/etc/collectd.conf
64 cp contrib/fedora/init.d-collectd $RPM_BUILD_ROOT/etc/rc.d/init.d/collectd
65 cp contrib/collection.cgi $RPM_BUILD_ROOT/var/www/cgi-bin
66 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
67 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
68 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 /sbin/chkconfig --add collectd
75 /sbin/chkconfig collectd on
76
77 #%postun
78 #/sbin/chkconfig collectd off
79 #/sbin/chkconfig --del collectd
80
81 %files
82 %defattr(-,root,root)
83 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
84 %config /etc/collectd.conf
85 %attr(0755,root,root) /etc/rc.d/init.d/collectd
86 %attr(0755,root,root) /var/www/cgi-bin/collection.cgi
87 %attr(0755,root,root) %{_sbindir}/collectd
88 %attr(0444,root,root) %{_mandir}/man1/*
89 %attr(0444,root,root) %{_mandir}/man5/*
90 %attr(0444,root,root) %{_libdir}/%{name}/apcups.so*
91 %attr(0444,root,root) %{_libdir}/%{name}/apple_sensors.so*
92 %attr(0444,root,root) %{_libdir}/%{name}/battery.so*
93 %attr(0444,root,root) %{_libdir}/%{name}/cpu.so*
94 %attr(0444,root,root) %{_libdir}/%{name}/cpufreq.so*
95 %attr(0444,root,root) %{_libdir}/%{name}/df.so*
96 %attr(0444,root,root) %{_libdir}/%{name}/disk.so*
97 %attr(0444,root,root) %{_libdir}/%{name}/dns.so
98 %attr(0444,root,root) %{_libdir}/%{name}/email.so
99 %attr(0444,root,root) %{_libdir}/%{name}/hddtemp.so*
100 %attr(0444,root,root) %{_libdir}/%{name}/irq.so*
101 %attr(0444,root,root) %{_libdir}/%{name}/load.so*
102 %attr(0444,root,root) %{_libdir}/%{name}/mbmon.so
103 %attr(0444,root,root) %{_libdir}/%{name}/memory.so*
104 %attr(0444,root,root) %{_libdir}/%{name}/multimeter.so*
105 %attr(0444,root,root) %{_libdir}/%{name}/nfs.so*
106 %attr(0444,root,root) %{_libdir}/%{name}/ntpd.so*
107 %attr(0444,root,root) %{_libdir}/%{name}/ping.so*
108 %attr(0444,root,root) %{_libdir}/%{name}/processes.so*
109 %attr(0444,root,root) %{_libdir}/%{name}/serial.so*
110 %attr(0444,root,root) %{_libdir}/%{name}/swap.so*
111 %attr(0444,root,root) %{_libdir}/%{name}/tape.so*
112 %attr(0444,root,root) %{_libdir}/%{name}/traffic.so*
113 %attr(0444,root,root) %{_libdir}/%{name}/users.so*
114 %attr(0444,root,root) %{_libdir}/%{name}/vserver.so*
115 %attr(0444,root,root) %{_libdir}/%{name}/wireless.so*
116
117 %dir /var/lib/collectd
118
119 %files apache
120 %attr(0444,root,root) %{_libdir}/%{name}/apache.so*
121
122 #%files email
123 #%attr(0444,root,root) %{_libdir}/%{name}/email.so
124
125 %files mysql
126 %attr(0444,root,root) %{_libdir}/%{name}/mysql.so*
127
128 %files sensors
129 %attr(0444,root,root) %{_libdir}/%{name}/sensors.so*
130
131 %changelog
132 * Wed Jan 11 2007 Iain Lea <iain@bricbrac.de> 3.11.0-0
133 - fixed spec file to build correctly on fedora core
134 - added improved init.d script to work with chkconfig
135 - added %post and %postun to call chkconfig automatically
136
137 * Sun Jul 09 2006 Florian octo Forster <octo@verplant.org> 3.10.0-1
138 - New upstream version
139
140 * Tue Jun 25 2006 Florian octo Forster <octo@verplant.org> 3.9.4-1
141 - New upstream version
142
143 * Tue Jun 01 2006 Florian octo Forster <octo@verplant.org> 3.9.3-1
144 - New upstream version
145
146 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.9.2-1
147 - New upstream version
148
149 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.8.5-1
150 - New upstream version
151
152 * Fri Apr 21 2006 Florian octo Forster <octo@verplant.org> 3.9.1-1
153 - New upstream version
154
155 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
156 - New upstream version
157 - Added the `apache' package.
158
159 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
160 - New upstream version
161
162 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
163 - New upstream version
164
165 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
166 - New upstream version
167
168 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
169 - Include `tape.so' so the build doesn't terminate because of missing files..
170 - New upstream version
171
172 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
173 - New upstream version
174
175 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
176 - New upstream version
177 - Removed the extra `hddtemp' package
178
179 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
180 - New upstream version
181
182 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
183 - New upstream version
184
185 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
186 - New upstream version
187 - Added config file, `collectd.conf(5)', `df.so'
188 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
189
190 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
191 - New upstream version
192
193 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
194 - New upstream version
195
196 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
197 - New upstream version
198
199 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
200 - New upstream version
201 - Added statement to remove the `*.la' files. This fixes a problem when
202   `Unpackaged files terminate build' is in effect.
203 - Added `processes.so*' to the main package
204
205 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
206 - New upstream version
207 - Added package `collectd-hddtemp'
208
209 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
210 - New upstream version
211 - Split the package into `collectd' and `collectd-sensors'
212
213 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
214 - New upstream version
215
216 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
217 - New upstream version
218
219 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
220 - New upstream version
221
222 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
223 - New upstream version
224
225 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
226 - New upstream version
227
228 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
229 - New upstream version
230
231 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
232 - New upstream version
233
234 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
235 - New upstream version
236
237 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
238 - Built on RedHat 7.3