Fixed Fedora specfile for Fedora 7 and collectd 4.0.5
[collectd.git] / contrib / fedora / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        4.0.5
4 Release:        0.fc0
5 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
6 License:        GPL
7 Group:          System Environment/Daemons
8 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9 BuildPrereq:    lm_sensors-devel, mysql-devel, rrdtool-devel
10 Requires:       rrdtool
11 Packager:       Florian octo Forster <octo@verplant.org>
12 Vendor:         Florian octo Forster <octo@verplant.org>
13
14 %description
15 collectd is a small daemon written in C for performance.  It reads various
16 system  statistics  and updates  RRD files,  creating  them if neccessary.
17 Since the daemon doesn't need to startup every time it wants to update the
18 files it's very fast and easy on the system. Also, the statistics are very
19 fine grained since the files are updated every 10 seconds.
20
21 %package apache
22 Summary:        apache-plugin for collectd.
23 Group:          System Environment/Daemons
24 Requires:       collectd = %{version}, curl
25 %description apache
26 This plugin collectd data provided by Apache's `mod_status'.
27
28 %package email
29 Summary:        email-plugin for collectd.
30 Group:          System Environment/Daemons
31 Requires:       collectd = %{version}, spamassassin
32 %description email
33 This plugin collectd data provided by spamassassin.
34
35 %package mysql
36 Summary:        mysql-module for collectd.
37 Group:          System Environment/Daemons
38 Requires:       collectd = %{version}, mysql
39 %description mysql
40 MySQL  querying  plugin.  This plugins  provides data of  issued commands,
41 called handlers and database traffic.
42
43 %package sensors
44 Summary:        libsensors-module for collectd.
45 Group:          System Environment/Daemons
46 Requires:       collectd = %{version}, lm_sensors
47 %description sensors
48 This  plugin  for  collectd  provides  querying  of sensors  supported  by
49 lm_sensors.
50
51 %prep
52 rm -rf $RPM_BUILD_ROOT
53 %setup
54
55 %build
56 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir}
57 make
58
59 %install
60 make install DESTDIR=$RPM_BUILD_ROOT
61 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
62 mkdir -p $RPM_BUILD_ROOT/var/www/cgi-bin
63 cp src/collectd.conf $RPM_BUILD_ROOT/etc/collectd.conf
64 cp contrib/fedora/init.d-collectd $RPM_BUILD_ROOT/etc/rc.d/init.d/collectd
65 cp contrib/collection.cgi $RPM_BUILD_ROOT/var/www/cgi-bin
66 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
67 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
68 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 /sbin/chkconfig --add collectd
75 /sbin/chkconfig collectd on
76
77 %preun
78 /sbin/chkconfig collectd off
79 /etc/init.d/collectd stop
80 /sbin/chkconfig --del collectd
81
82 %files
83 %defattr(-,root,root)
84 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
85 %config /etc/collectd.conf
86 %attr(0755,root,root) /etc/rc.d/init.d/collectd
87 %attr(0755,root,root) /var/www/cgi-bin/collection.cgi
88 %attr(0755,root,root) %{_sbindir}/collectd
89 %attr(0755,root,root) %{_bindir}/collectd-nagios
90 %attr(0644,root,root) %{_mandir}/man1/*
91 %attr(0644,root,root) %{_mandir}/man5/*
92
93 %attr(0644,root,root) %{_libdir}/%{name}/apcups.so*
94 %attr(0644,root,root) %{_libdir}/%{name}/apcups.la
95
96 %attr(0644,root,root) %{_libdir}/%{name}/apple_sensors.so*
97 %attr(0644,root,root) %{_libdir}/%{name}/apple_sensors.la
98
99 %attr(0644,root,root) %{_libdir}/%{name}/battery.so*
100 %attr(0644,root,root) %{_libdir}/%{name}/battery.la
101
102 %attr(0644,root,root) %{_libdir}/%{name}/cpufreq.so*
103 %attr(0644,root,root) %{_libdir}/%{name}/cpufreq.la
104
105 %attr(0644,root,root) %{_libdir}/%{name}/cpu.so*
106 %attr(0644,root,root) %{_libdir}/%{name}/cpu.la
107
108 %attr(0644,root,root) %{_libdir}/%{name}/csv.so*
109 %attr(0644,root,root) %{_libdir}/%{name}/csv.la
110
111 %attr(0644,root,root) %{_libdir}/%{name}/df.so*
112 %attr(0644,root,root) %{_libdir}/%{name}/df.la
113
114 %attr(0644,root,root) %{_libdir}/%{name}/disk.so*
115 %attr(0644,root,root) %{_libdir}/%{name}/disk.la
116
117 %attr(0644,root,root) %{_libdir}/%{name}/dns.so*
118 %attr(0644,root,root) %{_libdir}/%{name}/dns.la
119
120 %attr(0644,root,root) %{_libdir}/%{name}/entropy.so*
121 %attr(0644,root,root) %{_libdir}/%{name}/entropy.la
122
123 %attr(0644,root,root) %{_libdir}/%{name}/exec.so*
124 %attr(0644,root,root) %{_libdir}/%{name}/exec.la
125
126 %attr(0644,root,root) %{_libdir}/%{name}/hddtemp.so*
127 %attr(0644,root,root) %{_libdir}/%{name}/hddtemp.la
128
129 %attr(0644,root,root) %{_libdir}/%{name}/interface.so*
130 %attr(0644,root,root) %{_libdir}/%{name}/interface.la
131
132 %attr(0644,root,root) %{_libdir}/%{name}/iptables.so*
133 %attr(0644,root,root) %{_libdir}/%{name}/iptables.la
134
135 %attr(0644,root,root) %{_libdir}/%{name}/irq.so*
136 %attr(0644,root,root) %{_libdir}/%{name}/irq.la
137
138 %attr(0644,root,root) %{_libdir}/%{name}/load.so*
139 %attr(0644,root,root) %{_libdir}/%{name}/load.la
140
141 %attr(0644,root,root) %{_libdir}/%{name}/logfile.so*
142 %attr(0644,root,root) %{_libdir}/%{name}/logfile.la
143
144 %attr(0644,root,root) %{_libdir}/%{name}/mbmon.so
145 %attr(0644,root,root) %{_libdir}/%{name}/mbmon.la
146
147 %attr(0644,root,root) %{_libdir}/%{name}/memory.so*
148 %attr(0644,root,root) %{_libdir}/%{name}/memory.la
149
150 %attr(0644,root,root) %{_libdir}/%{name}/multimeter.so*
151 %attr(0644,root,root) %{_libdir}/%{name}/multimeter.la
152
153 %attr(0644,root,root) %{_libdir}/%{name}/network.so*
154 %attr(0644,root,root) %{_libdir}/%{name}/network.la
155
156 %attr(0644,root,root) %{_libdir}/%{name}/nfs.so*
157 %attr(0644,root,root) %{_libdir}/%{name}/nfs.la
158
159 %attr(0644,root,root) %{_libdir}/%{name}/ntpd.so*
160 %attr(0644,root,root) %{_libdir}/%{name}/ntpd.la
161
162 %attr(0644,root,root) %{_libdir}/%{name}/nut.so*
163 %attr(0644,root,root) %{_libdir}/%{name}/nut.la
164
165 %attr(0644,root,root) %{_libdir}/%{name}/perl.so*
166 %attr(0644,root,root) %{_libdir}/%{name}/perl.la
167
168 %attr(0644,root,root) %{_libdir}/%{name}/ping.so*
169 %attr(0644,root,root) %{_libdir}/%{name}/ping.la
170
171 %attr(0644,root,root) %{_libdir}/%{name}/processes.so*
172 %attr(0644,root,root) %{_libdir}/%{name}/processes.la
173
174 %attr(0644,root,root) %{_libdir}/%{name}/rrdtool.so*
175 %attr(0644,root,root) %{_libdir}/%{name}/rrdtool.la
176
177 %attr(0644,root,root) %{_libdir}/%{name}/serial.so*
178 %attr(0644,root,root) %{_libdir}/%{name}/serial.la
179
180 %attr(0644,root,root) %{_libdir}/%{name}/swap.so*
181 %attr(0644,root,root) %{_libdir}/%{name}/swap.la
182
183 %attr(0644,root,root) %{_libdir}/%{name}/syslog.so*
184 %attr(0644,root,root) %{_libdir}/%{name}/syslog.la
185
186 %attr(0644,root,root) %{_libdir}/%{name}/tape.so*
187 %attr(0644,root,root) %{_libdir}/%{name}/tape.la
188
189 %attr(0644,root,root) %{_libdir}/%{name}/unixsock.so*
190 %attr(0644,root,root) %{_libdir}/%{name}/unixsock.la
191
192 %attr(0644,root,root) %{_libdir}/%{name}/users.so*
193 %attr(0644,root,root) %{_libdir}/%{name}/users.la
194
195 %attr(0644,root,root) %{_libdir}/%{name}/vserver.so*
196 %attr(0644,root,root) %{_libdir}/%{name}/vserver.la
197
198 %attr(0644,root,root) %{_libdir}/%{name}/wireless.so*
199 %attr(0644,root,root) %{_libdir}/%{name}/wireless.la
200
201 %attr(0644,root,root) %{_libdir}/%{name}/types.db
202
203 %dir /var/lib/collectd
204
205 %files apache
206 %attr(0644,root,root) %{_libdir}/%{name}/apache.so*
207 %attr(0644,root,root) %{_libdir}/%{name}/apache.la
208
209 %files email
210 %attr(0644,root,root) %{_libdir}/%{name}/email.so*
211 %attr(0644,root,root) %{_libdir}/%{name}/email.la
212
213 %files mysql
214 %attr(0644,root,root) %{_libdir}/%{name}/mysql.so*
215 %attr(0644,root,root) %{_libdir}/%{name}/mysql.la
216
217 %files sensors
218 %attr(0644,root,root) %{_libdir}/%{name}/sensors.so*
219 %attr(0644,root,root) %{_libdir}/%{name}/sensors.la
220
221 %changelog
222 * Wed Jul 25 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.5
223 - New major releas
224 - Changes to support 4.0.5 
225
226 * Wed Jan 11 2007 Iain Lea <iain@bricbrac.de> 3.11.0-0
227 - fixed spec file to build correctly on fedora core
228 - added improved init.d script to work with chkconfig
229 - added %post and %postun to call chkconfig automatically
230
231 * Sun Jul 09 2006 Florian octo Forster <octo@verplant.org> 3.10.0-1
232 - New upstream version
233
234 * Tue Jun 25 2006 Florian octo Forster <octo@verplant.org> 3.9.4-1
235 - New upstream version
236
237 * Tue Jun 01 2006 Florian octo Forster <octo@verplant.org> 3.9.3-1
238 - New upstream version
239
240 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.9.2-1
241 - New upstream version
242
243 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.8.5-1
244 - New upstream version
245
246 * Fri Apr 21 2006 Florian octo Forster <octo@verplant.org> 3.9.1-1
247 - New upstream version
248
249 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
250 - New upstream version
251 - Added the `apache' package.
252
253 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
254 - New upstream version
255
256 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
257 - New upstream version
258
259 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
260 - New upstream version
261
262 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
263 - Include `tape.so' so the build doesn't terminate because of missing files..
264 - New upstream version
265
266 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
267 - New upstream version
268
269 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
270 - New upstream version
271 - Removed the extra `hddtemp' package
272
273 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
274 - New upstream version
275
276 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
277 - New upstream version
278
279 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
280 - New upstream version
281 - Added config file, `collectd.conf(5)', `df.so'
282 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
283
284 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
285 - New upstream version
286
287 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
288 - New upstream version
289
290 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
291 - New upstream version
292
293 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
294 - New upstream version
295 - Added statement to remove the `*.la' files. This fixes a problem when
296   `Unpackaged files terminate build' is in effect.
297 - Added `processes.so*' to the main package
298
299 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
300 - New upstream version
301 - Added package `collectd-hddtemp'
302
303 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
304 - New upstream version
305 - Split the package into `collectd' and `collectd-sensors'
306
307 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
308 - New upstream version
309
310 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
311 - New upstream version
312
313 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
314 - New upstream version
315
316 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
317 - New upstream version
318
319 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
320 - New upstream version
321
322 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
323 - New upstream version
324
325 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
326 - New upstream version
327
328 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
329 - New upstream version
330
331 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
332 - Built on RedHat 7.3