collectd.spec: Moved to `contrib/fedora/'.
[collectd.git] / contrib / fedora / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        3.11.0
4 Release:        0
5 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
6 License:        GPL
7 Group:          System Environment/Daemons
8 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9 BuildPrereq:    lm_sensors-devel, mysql-devel, rrdtool-devel
10 Requires:       rrdtool
11 Packager:       Florian octo Forster <octo@verplant.org>
12 Vendor:         Florian octo Forster <octo@verplant.org>
13
14 %description
15 collectd is a small daemon written in C for performance.  It reads various
16 system  statistics  and updates  RRD files,  creating  them if neccessary.
17 Since the daemon doesn't need to startup every time it wants to update the
18 files it's very fast and easy on the system. Also, the statistics are very
19 fine grained since the files are updated every 10 seconds.
20
21 %package apache
22 Summary:        apache-plugin for collectd.
23 Group:          System Environment/Daemons
24 Requires:       collectd = %{version}, libcurl3
25 %description apache
26 This plugin collectd data provided by Apache's `mod_status'.
27
28 #%package email
29 #Summary:       email-plugin for collectd.
30 #Group:         System Environment/Daemons
31 #Requires:      collectd = %{version}, spamassassin
32 #%description email
33 #This plugin collectd data provided by spamassassin.
34
35 %package mysql
36 Summary:        mysql-module for collectd.
37 Group:          System Environment/Daemons
38 Requires:       collectd = %{version}, mysql
39 %description mysql
40 MySQL  querying  plugin.  This plugins  provides data of  issued commands,
41 called handlers and database traffic.
42
43 %package sensors
44 Summary:        libsensors-module for collectd.
45 Group:          System Environment/Daemons
46 Requires:       collectd = %{version}, lm_sensors
47 %description sensors
48 This  plugin  for  collectd  provides  querying  of sensors  supported  by
49 lm_sensors.
50
51 %prep
52 rm -rf $RPM_BUILD_ROOT
53 %setup
54
55 %build
56 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir}
57 make
58
59 %install
60 make install DESTDIR=$RPM_BUILD_ROOT
61 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
62 mkdir -p $RPM_BUILD_ROOT/var/www/cgi-bin
63 cp src/collectd.conf $RPM_BUILD_ROOT/etc/collectd.conf
64 cp contrib/init.d-fc $RPM_BUILD_ROOT/etc/rc.d/init.d/collectd
65 cp contrib/collection.cgi $RPM_BUILD_ROOT/var/www/cgi-bin
66 #mv contrib/Collectd.pm contrib/Collectd.pm.DISABLED
67 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
68 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
69 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 /sbin/chkconfig --add collectd
76 /sbin/chkconfig collectd on
77
78 #%postun
79 #/sbin/chkconfig collectd off
80 #/sbin/chkconfig --del collectd
81
82 %files
83 %defattr(-,root,root)
84 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
85 #%doc contrib
86 %config /etc/collectd.conf
87 %attr(0755,root,root) /etc/rc.d/init.d/collectd
88 %attr(0755,root,root) /var/www/cgi-bin/collection.cgi
89 %attr(0755,root,root) %{_sbindir}/collectd
90 %attr(0444,root,root) %{_mandir}/man1/*
91 %attr(0444,root,root) %{_mandir}/man5/*
92 %attr(0444,root,root) %{_libdir}/%{name}/apcups.so*
93 %attr(0444,root,root) %{_libdir}/%{name}/apple_sensors.so*
94 %attr(0444,root,root) %{_libdir}/%{name}/battery.so*
95 %attr(0444,root,root) %{_libdir}/%{name}/cpu.so*
96 %attr(0444,root,root) %{_libdir}/%{name}/cpufreq.so*
97 %attr(0444,root,root) %{_libdir}/%{name}/df.so*
98 %attr(0444,root,root) %{_libdir}/%{name}/disk.so*
99 %attr(0444,root,root) %{_libdir}/%{name}/dns.so
100 %attr(0444,root,root) %{_libdir}/%{name}/email.so
101 %attr(0444,root,root) %{_libdir}/%{name}/hddtemp.so*
102 %attr(0444,root,root) %{_libdir}/%{name}/load.so*
103 %attr(0444,root,root) %{_libdir}/%{name}/mbmon.so
104 %attr(0444,root,root) %{_libdir}/%{name}/memory.so*
105 %attr(0444,root,root) %{_libdir}/%{name}/multimeter.so*
106 %attr(0444,root,root) %{_libdir}/%{name}/nfs.so*
107 %attr(0444,root,root) %{_libdir}/%{name}/ntpd.so*
108 %attr(0444,root,root) %{_libdir}/%{name}/ping.so*
109 %attr(0444,root,root) %{_libdir}/%{name}/processes.so*
110 %attr(0444,root,root) %{_libdir}/%{name}/serial.so*
111 %attr(0444,root,root) %{_libdir}/%{name}/swap.so*
112 %attr(0444,root,root) %{_libdir}/%{name}/tape.so*
113 %attr(0444,root,root) %{_libdir}/%{name}/traffic.so*
114 %attr(0444,root,root) %{_libdir}/%{name}/users.so*
115 %attr(0444,root,root) %{_libdir}/%{name}/vserver.so*
116 %attr(0444,root,root) %{_libdir}/%{name}/wireless.so*
117
118 %dir /var/lib/collectd
119
120 %files apache
121 %attr(0444,root,root) %{_libdir}/%{name}/apache.so*
122
123 #%files email
124 #%attr(0444,root,root) %{_libdir}/%{name}/email.so
125
126 %files mysql
127 %attr(0444,root,root) %{_libdir}/%{name}/mysql.so*
128
129 %files sensors
130 %attr(0444,root,root) %{_libdir}/%{name}/sensors.so*
131
132 %changelog
133 * Wed Jan 11 2007 Iain Lea <iain@bricbrac.de> 3.11.0-0
134 - fixed spec file to build correctly on fedora core
135 - added improved init.d script to work with chkconfig
136 - added %post and %postun to call chkconfig automatically
137
138 * Sun Jul 09 2006 Florian octo Forster <octo@verplant.org> 3.10.0-1
139 - New upstream version
140
141 * Tue Jun 25 2006 Florian octo Forster <octo@verplant.org> 3.9.4-1
142 - New upstream version
143
144 * Tue Jun 01 2006 Florian octo Forster <octo@verplant.org> 3.9.3-1
145 - New upstream version
146
147 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.9.2-1
148 - New upstream version
149
150 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.8.5-1
151 - New upstream version
152
153 * Fri Apr 21 2006 Florian octo Forster <octo@verplant.org> 3.9.1-1
154 - New upstream version
155
156 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
157 - New upstream version
158 - Added the `apache' package.
159
160 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
161 - New upstream version
162
163 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
164 - New upstream version
165
166 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
167 - New upstream version
168
169 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
170 - Include `tape.so' so the build doesn't terminate because of missing files..
171 - New upstream version
172
173 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
174 - New upstream version
175
176 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
177 - New upstream version
178 - Removed the extra `hddtemp' package
179
180 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
181 - New upstream version
182
183 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
184 - New upstream version
185
186 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
187 - New upstream version
188 - Added config file, `collectd.conf(5)', `df.so'
189 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
190
191 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
192 - New upstream version
193
194 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
195 - New upstream version
196
197 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
198 - New upstream version
199
200 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
201 - New upstream version
202 - Added statement to remove the `*.la' files. This fixes a problem when
203   `Unpackaged files terminate build' is in effect.
204 - Added `processes.so*' to the main package
205
206 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
207 - New upstream version
208 - Added package `collectd-hddtemp'
209
210 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
211 - New upstream version
212 - Split the package into `collectd' and `collectd-sensors'
213
214 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
215 - New upstream version
216
217 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
218 - New upstream version
219
220 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
221 - New upstream version
222
223 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
224 - New upstream version
225
226 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
227 - New upstream version
228
229 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
230 - New upstream version
231
232 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
233 - New upstream version
234
235 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
236 - New upstream version
237
238 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
239 - Built on RedHat 7.3