contrib/fedora/collectd.spec: Corrected the position of the init.d-script.
[collectd.git] / contrib / fedora / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        3.11.0
4 Release:        0.fc0
5 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
6 License:        GPL
7 Group:          System Environment/Daemons
8 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9 BuildPrereq:    lm_sensors-devel, mysql-devel, rrdtool-devel
10 Requires:       rrdtool
11 Packager:       Florian octo Forster <octo@verplant.org>
12 Vendor:         Florian octo Forster <octo@verplant.org>
13
14 %description
15 collectd is a small daemon written in C for performance.  It reads various
16 system  statistics  and updates  RRD files,  creating  them if neccessary.
17 Since the daemon doesn't need to startup every time it wants to update the
18 files it's very fast and easy on the system. Also, the statistics are very
19 fine grained since the files are updated every 10 seconds.
20
21 %package apache
22 Summary:        apache-plugin for collectd.
23 Group:          System Environment/Daemons
24 Requires:       collectd = %{version}, libcurl3
25 %description apache
26 This plugin collectd data provided by Apache's `mod_status'.
27
28 #%package email
29 #Summary:       email-plugin for collectd.
30 #Group:         System Environment/Daemons
31 #Requires:      collectd = %{version}, spamassassin
32 #%description email
33 #This plugin collectd data provided by spamassassin.
34
35 %package mysql
36 Summary:        mysql-module for collectd.
37 Group:          System Environment/Daemons
38 Requires:       collectd = %{version}, mysql
39 %description mysql
40 MySQL  querying  plugin.  This plugins  provides data of  issued commands,
41 called handlers and database traffic.
42
43 %package sensors
44 Summary:        libsensors-module for collectd.
45 Group:          System Environment/Daemons
46 Requires:       collectd = %{version}, lm_sensors
47 %description sensors
48 This  plugin  for  collectd  provides  querying  of sensors  supported  by
49 lm_sensors.
50
51 %prep
52 rm -rf $RPM_BUILD_ROOT
53 %setup
54
55 %build
56 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir}
57 make
58
59 %install
60 make install DESTDIR=$RPM_BUILD_ROOT
61 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
62 mkdir -p $RPM_BUILD_ROOT/var/www/cgi-bin
63 cp src/collectd.conf $RPM_BUILD_ROOT/etc/collectd.conf
64 cp contrib/fedora/init.d-collectd $RPM_BUILD_ROOT/etc/rc.d/init.d/collectd
65 cp contrib/collection.cgi $RPM_BUILD_ROOT/var/www/cgi-bin
66 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
67 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
68 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 /sbin/chkconfig --add collectd
75 /sbin/chkconfig collectd on
76
77 #%postun
78 #/sbin/chkconfig collectd off
79 #/sbin/chkconfig --del collectd
80
81 %files
82 %defattr(-,root,root)
83 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
84 %config /etc/collectd.conf
85 %attr(0755,root,root) /etc/rc.d/init.d/collectd
86 %attr(0755,root,root) /var/www/cgi-bin/collection.cgi
87 %attr(0755,root,root) %{_sbindir}/collectd
88 %attr(0444,root,root) %{_mandir}/man1/*
89 %attr(0444,root,root) %{_mandir}/man5/*
90 %attr(0444,root,root) %{_libdir}/%{name}/apcups.so*
91 %attr(0444,root,root) %{_libdir}/%{name}/apple_sensors.so*
92 %attr(0444,root,root) %{_libdir}/%{name}/battery.so*
93 %attr(0444,root,root) %{_libdir}/%{name}/cpu.so*
94 %attr(0444,root,root) %{_libdir}/%{name}/cpufreq.so*
95 %attr(0444,root,root) %{_libdir}/%{name}/df.so*
96 %attr(0444,root,root) %{_libdir}/%{name}/disk.so*
97 %attr(0444,root,root) %{_libdir}/%{name}/dns.so
98 %attr(0444,root,root) %{_libdir}/%{name}/email.so
99 %attr(0444,root,root) %{_libdir}/%{name}/hddtemp.so*
100 %attr(0444,root,root) %{_libdir}/%{name}/load.so*
101 %attr(0444,root,root) %{_libdir}/%{name}/mbmon.so
102 %attr(0444,root,root) %{_libdir}/%{name}/memory.so*
103 %attr(0444,root,root) %{_libdir}/%{name}/multimeter.so*
104 %attr(0444,root,root) %{_libdir}/%{name}/nfs.so*
105 %attr(0444,root,root) %{_libdir}/%{name}/ntpd.so*
106 %attr(0444,root,root) %{_libdir}/%{name}/ping.so*
107 %attr(0444,root,root) %{_libdir}/%{name}/processes.so*
108 %attr(0444,root,root) %{_libdir}/%{name}/serial.so*
109 %attr(0444,root,root) %{_libdir}/%{name}/swap.so*
110 %attr(0444,root,root) %{_libdir}/%{name}/tape.so*
111 %attr(0444,root,root) %{_libdir}/%{name}/traffic.so*
112 %attr(0444,root,root) %{_libdir}/%{name}/users.so*
113 %attr(0444,root,root) %{_libdir}/%{name}/vserver.so*
114 %attr(0444,root,root) %{_libdir}/%{name}/wireless.so*
115
116 %dir /var/lib/collectd
117
118 %files apache
119 %attr(0444,root,root) %{_libdir}/%{name}/apache.so*
120
121 #%files email
122 #%attr(0444,root,root) %{_libdir}/%{name}/email.so
123
124 %files mysql
125 %attr(0444,root,root) %{_libdir}/%{name}/mysql.so*
126
127 %files sensors
128 %attr(0444,root,root) %{_libdir}/%{name}/sensors.so*
129
130 %changelog
131 * Wed Jan 11 2007 Iain Lea <iain@bricbrac.de> 3.11.0-0
132 - fixed spec file to build correctly on fedora core
133 - added improved init.d script to work with chkconfig
134 - added %post and %postun to call chkconfig automatically
135
136 * Sun Jul 09 2006 Florian octo Forster <octo@verplant.org> 3.10.0-1
137 - New upstream version
138
139 * Tue Jun 25 2006 Florian octo Forster <octo@verplant.org> 3.9.4-1
140 - New upstream version
141
142 * Tue Jun 01 2006 Florian octo Forster <octo@verplant.org> 3.9.3-1
143 - New upstream version
144
145 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.9.2-1
146 - New upstream version
147
148 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.8.5-1
149 - New upstream version
150
151 * Fri Apr 21 2006 Florian octo Forster <octo@verplant.org> 3.9.1-1
152 - New upstream version
153
154 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
155 - New upstream version
156 - Added the `apache' package.
157
158 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
159 - New upstream version
160
161 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
162 - New upstream version
163
164 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
165 - New upstream version
166
167 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
168 - Include `tape.so' so the build doesn't terminate because of missing files..
169 - New upstream version
170
171 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
172 - New upstream version
173
174 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
175 - New upstream version
176 - Removed the extra `hddtemp' package
177
178 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
179 - New upstream version
180
181 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
182 - New upstream version
183
184 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
185 - New upstream version
186 - Added config file, `collectd.conf(5)', `df.so'
187 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
188
189 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
190 - New upstream version
191
192 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
193 - New upstream version
194
195 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
196 - New upstream version
197
198 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
199 - New upstream version
200 - Added statement to remove the `*.la' files. This fixes a problem when
201   `Unpackaged files terminate build' is in effect.
202 - Added `processes.so*' to the main package
203
204 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
205 - New upstream version
206 - Added package `collectd-hddtemp'
207
208 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
209 - New upstream version
210 - Split the package into `collectd' and `collectd-sensors'
211
212 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
213 - New upstream version
214
215 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
216 - New upstream version
217
218 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
219 - New upstream version
220
221 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
222 - New upstream version
223
224 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
225 - New upstream version
226
227 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
228 - New upstream version
229
230 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
231 - New upstream version
232
233 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
234 - New upstream version
235
236 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
237 - Built on RedHat 7.3