Auto-Merge pull request #3286 from mrunge/master
[collectd.git] / contrib / redhat / collectd.spec
index 1a1721b..55f1022 100644 (file)
 %define with_postgresql 0%{!?_without_postgresql:1}
 %define with_powerdns 0%{!?_without_powerdns:1}
 %define with_processes 0%{!?_without_processes:1}
+%define with_procevent 0%{!?_without_procevent:1}
 %define with_protocols 0%{!?_without_protocols:1}
 %define with_python 0%{!?_without_python:1}
 %define with_redis 0%{!?_without_redis:1}
 %define with_mqtt 0
 %define with_ovs_events 0
 %define with_ovs_stats 0
+%define with_procevent 0
 %define with_redis 0
 %define with_rrdcached 0
 %define with_sysevent 0
@@ -387,9 +389,9 @@ Chrony plugin for collectd
 %if %{with_connectivity}
 %package connectivity
 Summary:       Connectivity plugin for collectd
-Group:        System Environment/Daemons
+Group:         System Environment/Daemons
 Requires:      %{name}%{?_isa} = %{version}-%{release}
-BuildRequires: yajl-devel
+BuildRequires: libmnl-devel, yajl-devel
 %description connectivity
 Monitors network interface up/down status via netlink library.
 %endif
@@ -806,6 +808,16 @@ The PostgreSQL plugin connects to and executes SQL statements on a PostgreSQL
 database.
 %endif
 
+%if %{with_procevent}
+%package procevent
+Summary:       Processes event plugin for collectd
+Group:         System Environment/Daemons
+Requires:      %{name}%{?_isa} = %{version}-%{release}
+BuildRequires: yajl-devel
+%description procevent
+Monitors process starts/stops via netlink library.
+%endif
+
 %if %{with_python}
 %package python
 Summary:       Python plugin for collectd
@@ -1160,11 +1172,11 @@ Collectd utilities
 %define _with_chrony --disable-chrony
 %endif
 
-+%if %{with_connectivity}
-+%define _with_connectivity --enable-connectivity
-+%else
-+%define _with_connectivity --disable-connectivity
-+%endif
+%if %{with_connectivity}
+%define _with_connectivity --enable-connectivity
+%else
+%define _with_connectivity --disable-connectivity
+%endif
 
 %if %{with_conntrack}
 %define _with_conntrack --enable-conntrack
@@ -1664,6 +1676,12 @@ Collectd utilities
 %define _with_processes --disable-processes
 %endif
 
+%if %{with_procevent}
+%define _with_procevent --enable-procevent
+%else
+%define _with_procevent --disable-procevent
+%endif
+
 %if %{with_protocols}
 %define _with_protocols --enable-protocols
 %else
@@ -2110,6 +2128,7 @@ Collectd utilities
        %{?_with_postgresql} \
        %{?_with_powerdns} \
        %{?_with_processes} \
+       %{?_with_procevent} \
        %{?_with_protocols} \
        %{?_with_python} \
        %{?_with_redis} \
@@ -2791,6 +2810,11 @@ fi
 %{_libdir}/%{name}/postgresql.so
 %endif
 
+%if %{with_procevent}
+%files procevent
+%{_libdir}/%{name}/procevent.so
+%endif
+
 %if %{with_python}
 %files python
 %{_mandir}/man5/collectd-python*