Updated `collectd.spec', though not tested it..
[collectd.git] / debian / rules
index 25a9e29..c11a195 100755 (executable)
@@ -18,7 +18,7 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 CFLAGS = -Wall -g
 
-PLUGINS = cpu cpufreq disk hddtemp load memory nfs ping processes sensors serial swap traffic users
+PLUGINS = hddtemp mysql sensors
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -72,6 +72,8 @@ install: build
 
        # Add here commands to install the package into debian/collectd.
        $(MAKE) DESTDIR=$(CURDIR)/debian/collectd install
+       mkdir -p $(CURDIR)/debian/collectd/etc
+       cp contrib/collectd.conf $(CURDIR)/debian/collectd/etc/
        rm $(CURDIR)/debian/collectd/usr/lib/collectd/*.a  || true
        rm $(CURDIR)/debian/collectd/usr/lib/collectd/*.la || true