Merge pull request #2624 from abays/sysevent
[collectd.git] / contrib / redhat / collectd.spec
index ddb47a3..4c566a2 100644 (file)
 %define with_statsd 0%{!?_without_statsd:1}
 %define with_swap 0%{!?_without_swap:1}
 %define with_synproxy 0%{!?_without_synproxy:0}
+%define with_sysevent 0%{!?_without_sysevent:1}
 %define with_syslog 0%{!?_without_syslog:1}
 %define with_table 0%{!?_without_table:1}
 %define with_tail 0%{!?_without_tail:1}
 %define with_xencpu 0%{!?_without_xencpu:0}
 # plugin zone disabled, requires Solaris
 %define with_zone 0%{!?_without_zone:0}
-# requires cuda (I think)
+# plugin gpu_nvidia requires cuda-nvml-dev
+# get it from https://developer.nvidia.com/cuda-downloads
+# then install cuda-nvml-dev-10-1 or other version
 %define with_gpu_nvidia 0%{!?_without_gpu_nvidia:0}
 # not sure why this one's failing
 %define with_write_stackdriver 0%{!?_without_write_stackdriver:0}
 %define with_ovs_stats 0
 %define with_redis 0
 %define with_rrdcached 0
+%define with_sysevent 0
 %define with_write_redis 0
 %define with_write_riemann 0
 %define with_xmms 0
@@ -889,6 +893,16 @@ BuildRequires:     net-snmp-devel
 This plugin for collectd to support AgentX integration.
 %endif
 
+%if %{with_sysevent}
+%package sysevent
+Summary:       Rsyslog event plugin for collectd
+Group:         System Environment/Daemons
+Requires:      %{name}%{?_isa} = %{version}-%{release}
+BuildRequires: yajl-devel
+%description sysevent
+Monitors rsyslog for system events.
+%endif
+
 %if %{with_varnish}
 %package varnish
 Summary:       Varnish plugin for collectd
@@ -966,7 +980,7 @@ The riemann plugin submits values to Riemann, an event stream processor.
 Summary:       stackdriver plugin for collectd
 Group:         System Environment/Daemons
 Requires:      %{name}%{?_isa} = %{version}-%{release}
-BuildRequires: curl-devel, libxml2-devel, liboauth-devel
+BuildRequires: curl-devel, yajl-devel, openssl-devel
 %description write_stackdriver
 The write_stackdriver collectd plugin writes metrics to the
 Google Stackdriver Monitoring service.
@@ -977,7 +991,7 @@ Google Stackdriver Monitoring service.
 Summary:       stackdriver plugin for collectd
 Group:         System Environment/Daemons
 Requires:      %{name}%{?_isa} = %{version}-%{release}
-BuildRequires: curl-devel, libxml2-devel, liboauth-devel
+BuildRequires: cuda-nvml-dev-10-1
 %description gpu_nvidia
 The gpu_nvidia collectd plugin collects NVidia GPU metrics.
 %endif
@@ -1727,6 +1741,12 @@ Collectd utilities
 %define _with_synproxy --disable-synproxy
 %endif
 
+%if %{with_sysevent}
+%define _with_sysevent --enable-sysevent
+%else
+%define _with_sysevent --disable-sysevent
+%endif
+
 %if %{with_syslog}
 %define _with_syslog --enable-syslog
 %else
@@ -2086,6 +2106,7 @@ Collectd utilities
        %{?_with_statsd} \
        %{?_with_swap} \
        %{?_with_synproxy} \
+       %{?_with_sysevent} \
        %{?_with_syslog} \
        %{?_with_table} \
        %{?_with_tail_csv} \
@@ -2793,6 +2814,11 @@ fi
 %{_libdir}/%{name}/snmp_agent.so
 %endif
 
+%if %{with_sysevent}
+%files sysevent
+%{_libdir}/%{name}/sysevent.so
+%endif
+
 %if %{with_varnish}
 %files varnish
 %{_libdir}/%{name}/varnish.so