virt plugin: Disable tests momentarily
[collectd.git] / src / Makefile.am
index 0601ce9..a389b3c 100644 (file)
@@ -1284,9 +1284,12 @@ test_plugin_virt_CPPFLAGS = $(AM_CPPFLAGS) \
 test_plugin_virt_LDFLAGS = $(PLUGIN_LDFLAGS)
 test_plugin_virt_LDADD = daemon/libplugin_mock.la \
                $(BUILD_WITH_LIBVIRT_LIBS) $(BUILD_WITH_LIBXML2_LIBS)
-check_PROGRAMS += test_plugin_virt
-TESTS += test_plugin_virt
-
+# TODO: enable once we support only modern libvirts which depends on libnl-3
+# the libvirt on wheezy is linked in libnl v1, and there is a small leak here,
+# triggered by the library initialization. There are no means to avoid it,
+# and libvirt switched to libnl3 anyway
+#check_PROGRAMS += test_plugin_virt
+#TESTS += test_plugin_virt
 endif
 
 if BUILD_PLUGIN_VMEM