Merge branch 'sb/iptables'
[collectd.git] / src / Makefile.am
index 2e2d637..aee7479 100644 (file)
@@ -208,6 +208,17 @@ collectd_LDADD += "-dlopen" hddtemp.la
 collectd_DEPENDENCIES += hddtemp.la
 endif
 
+if BUILD_MODULE_IPTABLES
+pkglib_LTLIBRARIES += iptables.la
+iptables_la_SOURCES = iptables.c
+iptables_la_LDFLAGS = -module -avoid-version
+if BUILD_WITH_LIBIPTC
+iptables_la_LDFLAGS += -liptc
+endif
+collectd_LDADD += "-dlopen" iptables.la
+collectd_DEPENDENCIES += iptables.la
+endif
+
 if BUILD_MODULE_IRQ
 pkglib_LTLIBRARIES += irq.la
 irq_la_SOURCES = irq.c