perl plugin: plugins are linked with *_LIBADD and LIBS not *_LIBS and LIBS
[collectd.git] / src / Makefile.am
index 23c3a3b..1eb5d70 100644 (file)
@@ -891,7 +891,7 @@ perl_la_CFLAGS += -Wno-nonnull
 endif
 perl_la_LDFLAGS = -module -avoid-version \
                $(PERL_LDFLAGS)
-perl_la_LIBS = $(PERL_LIBS)
+perl_la_LIBADD = $(PERL_LIBS)
 collectd_LDADD += "-dlopen" perl.la
 collectd_DEPENDENCIES += perl.la
 endif