Merge branch 'collectd-4.5'
[collectd.git] / src / Makefile.am
index d868f96..35747e7 100644 (file)
@@ -403,6 +403,14 @@ collectd_LDADD += "-dlopen" match_regex.la
 collectd_DEPENDENCIES += match_regex.la
 endif
 
+if BUILD_PLUGIN_MATCH_VALUE
+pkglib_LTLIBRARIES += match_value.la
+match_value_la_SOURCES = match_value.c
+match_value_la_LDFLAGS = -module -avoid-version
+collectd_LDADD += "-dlopen" match_value.la
+collectd_DEPENDENCIES += match_value.la
+endif
+
 if BUILD_PLUGIN_MBMON
 pkglib_LTLIBRARIES += mbmon.la
 mbmon_la_SOURCES = mbmon.c
@@ -859,7 +867,7 @@ EXTRA_DIST += collectd-email.pod collectd-exec.pod collectd-nagios.pod \
 .pod.1:
        pod2man --release=$(VERSION) --center=$(PACKAGE) $< \
                >.pod2man.tmp 2>/dev/null && mv -f .pod2man.tmp $@ || true
-       if grep '\<POD ERRORS\>' $@ >/dev/null 2>&1; \
+       @if grep '\<POD ERRORS\>' $@ >/dev/null 2>&1; \
        then \
                echo "$@ has some POD errors!"; false; \
        fi
@@ -867,7 +875,7 @@ EXTRA_DIST += collectd-email.pod collectd-exec.pod collectd-nagios.pod \
 .pod.5:
        pod2man --section=5 --release=$(VERSION) --center=$(PACKAGE) $< \
                >.pod2man.tmp 2>/dev/null && mv -f .pod2man.tmp $@ || true
-       if grep '\<POD ERRORS\>' $@ >/dev/null 2>&1; \
+       @if grep '\<POD ERRORS\>' $@ >/dev/null 2>&1; \
        then \
                echo "$@ has some POD errors!"; false; \
        fi