Include turbostat plugin during compilation
[collectd.git] / src / Makefile.am
index 004fc94..6a5c53a 100644 (file)
@@ -1060,6 +1060,14 @@ tokyotyrant_la_LIBADD += -lsocket
 endif
 endif
 
+if BUILD_PLUGIN_TURBOSTAT
+pkglib_LTLIBRARIES += turbostat.la
+turbostat_la_SOURCES = turbostat.c
+turbostat_la_LDFLAGS = -module -avoid-version
+collectd_LDADD += "-dlopen" turbostat.la
+collectd_DEPENDENCIES += turbostat.la
+endif
+
 if BUILD_PLUGIN_UNIXSOCK
 pkglib_LTLIBRARIES += unixsock.la
 unixsock_la_SOURCES = unixsock.c \