Build system: Properly integrated src/libesl/.
[collectd.git] / src / libesl / Makefile.am
diff --git a/src/libesl/Makefile.am b/src/libesl/Makefile.am
new file mode 100644 (file)
index 0000000..b6e254a
--- /dev/null
@@ -0,0 +1,23 @@
+AUTOMAKE_OPTIONS = foreign no-dependencies
+
+#EXTRA_DIST = libiptc.c README.collectd
+
+if COMPILER_IS_GCC
+AM_CFLAGS = -Wall -Werror
+endif
+
+noinst_LTLIBRARIES = libesl.la
+
+libesl_la_SOURCES = esl.c \
+                    esl_config.c \
+                    esl_config.h \
+                    esl_event.c \
+                    esl_event.h \
+                    esl.h \
+                    esl_oop.cpp \
+                    esl_oop.h \
+                    esl_threadmutex.c \
+                    esl_threadmutex.h
+#libesl_la_CFLAGS = -I$(KERNEL_DIR)/include
+
+