Merged revision 6.4.5 from `trunk' to `tags/collectd-3.9.1'
[collectd.git] / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        3.9.0
4 Release:        1
5 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
6 License:        GPL
7 Group:          System Environment/Daemons
8 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9 BuildPrereq:    lm_sensors-devel, mysql-devel, rrdtool-devel
10 Requires:       rrdtool
11 Packager:       Florian octo Forster <octo@verplant.org>
12 Vendor:         Florian octo Forster <octo@verplant.org>
13
14 %description
15 collectd is a small daemon written in C for performance.  It reads various
16 system  statistics  and updates  RRD files,  creating  them if neccessary.
17 Since the daemon doesn't need to startup every time it wants to update the
18 files it's very fast and easy on the system. Also, the statistics are very
19 fine grained since the files are updated every 10 seconds.
20
21 %package apache
22 Summary:        apache-plugin for collectd.
23 Group:          System Environment/Daemons
24 Requires:       collectd = %{version}, libcurl3
25 %description apache
26 This plugin collectd data provided by Apache's `mod_status'.
27
28 %package mysql
29 Summary:        mysql-module for collectd.
30 Group:          System Environment/Daemons
31 Requires:       collectd = %{version}, mysql
32 %description mysql
33 MySQL  querying  plugin.  This plugins  provides data of  issued commands,
34 called handlers and database traffic.
35
36 %package sensors
37 Summary:        libsensors-module for collectd.
38 Group:          System Environment/Daemons
39 Requires:       collectd = %{version}, lm_sensors
40 %description sensors
41 This  plugin  for  collectd  provides  querying  of sensors  supported  by
42 lm_sensors.
43
44 %prep
45 rm -rf $RPM_BUILD_ROOT
46 %setup
47
48 %build
49 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir}
50 make
51
52 %install
53 make install DESTDIR=$RPM_BUILD_ROOT
54 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
55 cp contrib/collectd.conf $RPM_BUILD_ROOT/etc/collectd.conf
56 cp contrib/init.d-rh7 $RPM_BUILD_ROOT/etc/rc.d/init.d/collectd
57 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
58 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
59 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(-,root,root)
66 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
67 %doc contrib
68 %config /etc/collectd.conf
69 %attr(0755,root,root) /etc/rc.d/init.d/collectd
70 %attr(0755,root,root) %{_sbindir}/collectd
71 %attr(0444,root,root) %{_mandir}/man1/*
72 %attr(0444,root,root) %{_mandir}/man5/*
73 %attr(0444,root,root) %{_libdir}/%{name}/apple_sensors.so*
74 %attr(0444,root,root) %{_libdir}/%{name}/battery.so*
75 %attr(0444,root,root) %{_libdir}/%{name}/cpu.so*
76 %attr(0444,root,root) %{_libdir}/%{name}/cpufreq.so*
77 %attr(0444,root,root) %{_libdir}/%{name}/df.so*
78 %attr(0444,root,root) %{_libdir}/%{name}/disk.so*
79 %attr(0444,root,root) %{_libdir}/%{name}/hddtemp.so*
80 %attr(0444,root,root) %{_libdir}/%{name}/load.so*
81 %attr(0444,root,root) %{_libdir}/%{name}/memory.so*
82 %attr(0444,root,root) %{_libdir}/%{name}/nfs.so*
83 %attr(0444,root,root) %{_libdir}/%{name}/ping.so*
84 %attr(0444,root,root) %{_libdir}/%{name}/processes.so*
85 %attr(0444,root,root) %{_libdir}/%{name}/serial.so*
86 %attr(0444,root,root) %{_libdir}/%{name}/swap.so*
87 %attr(0444,root,root) %{_libdir}/%{name}/tape.so*
88 %attr(0444,root,root) %{_libdir}/%{name}/traffic.so*
89 %attr(0444,root,root) %{_libdir}/%{name}/users.so*
90 %attr(0444,root,root) %{_libdir}/%{name}/vserver.so*
91 %attr(0444,root,root) %{_libdir}/%{name}/wireless.so*
92 %dir /var/lib/collectd
93
94 %files apache
95 %attr(0444,root,root) %{_libdir}/%{name}/apache.so*
96
97 %files mysql
98 %attr(0444,root,root) %{_libdir}/%{name}/mysql.so*
99
100 %files sensors
101 %attr(0444,root,root) %{_libdir}/%{name}/sensors.so*
102
103 %changelog
104 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
105 - New upstream version
106 - Added the `apache' package.
107
108 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
109 - New upstream version
110
111 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
112 - New upstream version
113
114 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
115 - New upstream version
116
117 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
118 - Include `tape.so' so the build doesn't terminate because of missing files..
119 - New upstream version
120
121 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
122 - New upstream version
123
124 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
125 - New upstream version
126 - Removed the extra `hddtemp' package
127
128 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
129 - New upstream version
130
131 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
132 - New upstream version
133
134 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
135 - New upstream version
136 - Added config file, `collectd.conf(5)', `df.so'
137 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
138
139 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
140 - New upstream version
141
142 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
143 - New upstream version
144
145 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
146 - New upstream version
147
148 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
149 - New upstream version
150 - Added statement to remove the `*.la' files. This fixes a problem when
151   `Unpackaged files terminate build' is in effect.
152 - Added `processes.so*' to the main package
153
154 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
155 - New upstream version
156 - Added package `collectd-hddtemp'
157
158 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
159 - New upstream version
160 - Split the package into `collectd' and `collectd-sensors'
161
162 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
163 - New upstream version
164
165 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
166 - New upstream version
167
168 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
169 - New upstream version
170
171 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
172 - New upstream version
173
174 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
175 - New upstream version
176
177 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
178 - New upstream version
179
180 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
181 - New upstream version
182
183 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
184 - New upstream version
185
186 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
187 - Built on RedHat 7.3