plugin_dispatch_multivalue: Submit NAN when computing percantage of an empty set.
[collectd.git] / contrib / fedora / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        4.2.0
4 Release:        1.fc6
5 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
6 License:        GPL
7 Group:          System Environment/Daemons
8 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9 BuildPrereq:    lm_sensors-devel
10 BuildPrereq:    mysql-devel
11 BuildPrereq:    rrdtool-devel
12 BuildPrereq:    net-snmp-devel
13 Requires:       rrdtool
14 Requires:       perl-Regexp-Common
15 Packager:       Florian octo Forster <octo@verplant.org>
16 Vendor:         Florian octo Forster <octo@verplant.org>
17
18 %description
19 collectd is a small daemon written in C for performance.  It reads various
20 system  statistics  and updates  RRD files,  creating  them if neccessary.
21 Since the daemon doesn't need to startup every time it wants to update the
22 files it's very fast and easy on the system. Also, the statistics are very
23 fine grained since the files are updated every 10 seconds.
24
25 %package apache
26 Summary:        apache-plugin for collectd.
27 Group:          System Environment/Daemons
28 Requires:       collectd = %{version}, curl
29 %description apache
30 This plugin collectd data provided by Apache's `mod_status'.
31
32 %package email
33 Summary:        email-plugin for collectd.
34 Group:          System Environment/Daemons
35 Requires:       collectd = %{version}, spamassassin
36 %description email
37 This plugin collectd data provided by spamassassin.
38
39 %package mysql
40 Summary:        mysql-module for collectd.
41 Group:          System Environment/Daemons
42 Requires:       collectd = %{version}, mysql
43 %description mysql
44 MySQL  querying  plugin.  This plugins  provides data of  issued commands,
45 called handlers and database traffic.
46
47 %package sensors
48 Summary:        libsensors-module for collectd.
49 Group:          System Environment/Daemons
50 Requires:       collectd = %{version}, lm_sensors
51 %description sensors
52 This  plugin  for  collectd  provides  querying  of sensors  supported  by
53 lm_sensors.
54
55 %prep
56 rm -rf $RPM_BUILD_ROOT
57 %setup
58
59 %build
60 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir}
61 make
62
63 %install
64 make install DESTDIR=$RPM_BUILD_ROOT
65 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
66 mkdir -p $RPM_BUILD_ROOT/var/www/cgi-bin
67 cp src/collectd.conf $RPM_BUILD_ROOT/etc/collectd.conf
68 cp contrib/fedora/init.d-collectd $RPM_BUILD_ROOT/etc/rc.d/init.d/collectd
69 cp contrib/collection.cgi $RPM_BUILD_ROOT/var/www/cgi-bin
70 cp contrib/collection.conf $RPM_BUILD_ROOT/etc/collection.conf
71 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 /sbin/chkconfig --add collectd
78 /sbin/chkconfig collectd on
79
80 %preun
81 if [ "$1" = 0 ]; then
82    /sbin/chkconfig collectd off
83    /etc/init.d/collectd stop
84    /sbin/chkconfig --del collectd
85 fi
86 exit 0
87
88 %postun
89 if [ "$1" -ge 1 ]; then
90     /etc/init.d/collectd restart
91 fi
92 exit 0
93
94 %files
95 %defattr(-,root,root)
96 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
97 %attr(0644,root,root) %config(noreplace) /etc/collectd.conf
98 %attr(0644,root,root) %config(noreplace) /etc/collection.conf
99 %attr(0755,root,root) /etc/rc.d/init.d/collectd
100 %attr(0755,root,root) /var/www/cgi-bin/collection.cgi
101 %attr(0755,root,root) %{_sbindir}/collectd
102 %attr(0755,root,root) %{_bindir}/collectd-nagios
103 %attr(0644,root,root) %{_mandir}/man1/*
104 %attr(0644,root,root) %{_mandir}/man5/*
105
106 %attr(0644,root,root) /usr/lib/perl5/5.8.8/i386-linux-thread-multi/perllocal.pod
107 %attr(0644,root,root) /usr/lib/perl5/site_perl/5.8.8/Collectd.pm
108 %attr(0644,root,root) /usr/lib/perl5/site_perl/5.8.8/Collectd/Unixsock.pm
109 %attr(0644,root,root) /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/Collectd/.packlist
110 %attr(0644,root,root) %{_mandir}/man3/Collectd::Unixsock.3pm.gz
111
112 %attr(0644,root,root) %{_libdir}/%{name}/apcups.so*
113 %attr(0644,root,root) %{_libdir}/%{name}/apcups.la
114
115 # FIXME!!!
116 #%attr(0644,root,root) %{_libdir}/%{name}/apple_sensors.so*
117 #%attr(0644,root,root) %{_libdir}/%{name}/apple_sensors.la
118
119 %attr(0644,root,root) %{_libdir}/%{name}/battery.so*
120 %attr(0644,root,root) %{_libdir}/%{name}/battery.la
121
122 %attr(0644,root,root) %{_libdir}/%{name}/conntrack.so*
123 %attr(0644,root,root) %{_libdir}/%{name}/conntrack.la
124
125 %attr(0644,root,root) %{_libdir}/%{name}/cpufreq.so*
126 %attr(0644,root,root) %{_libdir}/%{name}/cpufreq.la
127
128 %attr(0644,root,root) %{_libdir}/%{name}/cpu.so*
129 %attr(0644,root,root) %{_libdir}/%{name}/cpu.la
130
131 %attr(0644,root,root) %{_libdir}/%{name}/csv.so*
132 %attr(0644,root,root) %{_libdir}/%{name}/csv.la
133
134 %attr(0644,root,root) %{_libdir}/%{name}/df.so*
135 %attr(0644,root,root) %{_libdir}/%{name}/df.la
136
137 %attr(0644,root,root) %{_libdir}/%{name}/disk.so*
138 %attr(0644,root,root) %{_libdir}/%{name}/disk.la
139
140 %attr(0644,root,root) %{_libdir}/%{name}/dns.so*
141 %attr(0644,root,root) %{_libdir}/%{name}/dns.la
142
143 %attr(0644,root,root) %{_libdir}/%{name}/entropy.so*
144 %attr(0644,root,root) %{_libdir}/%{name}/entropy.la
145
146 %attr(0644,root,root) %{_libdir}/%{name}/exec.so*
147 %attr(0644,root,root) %{_libdir}/%{name}/exec.la
148
149 %attr(0644,root,root) %{_libdir}/%{name}/hddtemp.so*
150 %attr(0644,root,root) %{_libdir}/%{name}/hddtemp.la
151
152 %attr(0644,root,root) %{_libdir}/%{name}/interface.so*
153 %attr(0644,root,root) %{_libdir}/%{name}/interface.la
154
155 %attr(0644,root,root) %{_libdir}/%{name}/iptables.so*
156 %attr(0644,root,root) %{_libdir}/%{name}/iptables.la
157
158 %attr(0644,root,root) %{_libdir}/%{name}/irq.so*
159 %attr(0644,root,root) %{_libdir}/%{name}/irq.la
160
161 %attr(0644,root,root) %{_libdir}/%{name}/load.so*
162 %attr(0644,root,root) %{_libdir}/%{name}/load.la
163
164 %attr(0644,root,root) %{_libdir}/%{name}/logfile.so*
165 %attr(0644,root,root) %{_libdir}/%{name}/logfile.la
166
167 %attr(0644,root,root) %{_libdir}/%{name}/mbmon.so*
168 %attr(0644,root,root) %{_libdir}/%{name}/mbmon.la
169
170 %attr(0644,root,root) %{_libdir}/%{name}/memcached.so*
171 %attr(0644,root,root) %{_libdir}/%{name}/memcached.la
172
173 %attr(0644,root,root) %{_libdir}/%{name}/memory.so*
174 %attr(0644,root,root) %{_libdir}/%{name}/memory.la
175
176 %attr(0644,root,root) %{_libdir}/%{name}/multimeter.so*
177 %attr(0644,root,root) %{_libdir}/%{name}/multimeter.la
178
179 %attr(0644,root,root) %{_libdir}/%{name}/network.so*
180 %attr(0644,root,root) %{_libdir}/%{name}/network.la
181
182 %attr(0644,root,root) %{_libdir}/%{name}/nfs.so*
183 %attr(0644,root,root) %{_libdir}/%{name}/nfs.la
184
185 %attr(0644,root,root) %{_libdir}/%{name}/nginx.so*
186 %attr(0644,root,root) %{_libdir}/%{name}/nginx.la
187
188 %attr(0644,root,root) %{_libdir}/%{name}/ntpd.so*
189 %attr(0644,root,root) %{_libdir}/%{name}/ntpd.la
190
191 # FIXME!!!
192 #%attr(0644,root,root) %{_libdir}/%{name}/nut.so*
193 #%attr(0644,root,root) %{_libdir}/%{name}/nut.la
194
195 %attr(0644,root,root) %{_libdir}/%{name}/perl.so*
196 %attr(0644,root,root) %{_libdir}/%{name}/perl.la
197
198 %attr(0644,root,root) %{_libdir}/%{name}/ping.so*
199 %attr(0644,root,root) %{_libdir}/%{name}/ping.la
200
201 %attr(0644,root,root) %{_libdir}/%{name}/processes.so*
202 %attr(0644,root,root) %{_libdir}/%{name}/processes.la
203
204 %attr(0644,root,root) %{_libdir}/%{name}/rrdtool.so*
205 %attr(0644,root,root) %{_libdir}/%{name}/rrdtool.la
206
207 %attr(0644,root,root) %{_libdir}/%{name}/serial.so*
208 %attr(0644,root,root) %{_libdir}/%{name}/serial.la
209
210 %attr(0644,root,root) %{_libdir}/%{name}/swap.so*
211 %attr(0644,root,root) %{_libdir}/%{name}/swap.la
212
213 %attr(0644,root,root) %{_libdir}/%{name}/snmp.so*
214 %attr(0644,root,root) %{_libdir}/%{name}/snmp.la
215
216 %attr(0644,root,root) %{_libdir}/%{name}/syslog.so*
217 %attr(0644,root,root) %{_libdir}/%{name}/syslog.la
218
219 # FIXME!!!
220 #%attr(0644,root,root) %{_libdir}/%{name}/tape.so*
221 #%attr(0644,root,root) %{_libdir}/%{name}/tape.la
222
223 %attr(0644,root,root) %{_libdir}/%{name}/tcpconns.so*
224 %attr(0644,root,root) %{_libdir}/%{name}/tcpconns.la
225
226 %attr(0644,root,root) %{_libdir}/%{name}/unixsock.so*
227 %attr(0644,root,root) %{_libdir}/%{name}/unixsock.la
228
229 %attr(0644,root,root) %{_libdir}/%{name}/users.so*
230 %attr(0644,root,root) %{_libdir}/%{name}/users.la
231
232 %attr(0644,root,root) %{_libdir}/%{name}/vserver.so*
233 %attr(0644,root,root) %{_libdir}/%{name}/vserver.la
234
235 %attr(0644,root,root) %{_libdir}/%{name}/wireless.so*
236 %attr(0644,root,root) %{_libdir}/%{name}/wireless.la
237
238 %attr(0644,root,root) %{_datadir}/%{name}/types.db
239
240 %dir /var/lib/collectd
241
242 %files apache
243 %attr(0644,root,root) %{_libdir}/%{name}/apache.so*
244 %attr(0644,root,root) %{_libdir}/%{name}/apache.la
245
246 %files email
247 %attr(0644,root,root) %{_libdir}/%{name}/email.so*
248 %attr(0644,root,root) %{_libdir}/%{name}/email.la
249
250 %files mysql
251 %attr(0644,root,root) %{_libdir}/%{name}/mysql.so*
252 %attr(0644,root,root) %{_libdir}/%{name}/mysql.la
253
254 %files sensors
255 %attr(0644,root,root) %{_libdir}/%{name}/sensors.so*
256 %attr(0644,root,root) %{_libdir}/%{name}/sensors.la
257
258 %changelog
259 * Wed Oct 31 2007 Iain Lea <iain@bricbrac.de> 4.2.0
260 - New major release
261 - Changes to support 4.2.0 (ie. contrib/collection.conf)
262
263 * Mon Aug 06 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.6
264 - New upstream version
265
266 * Wed Jul 25 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.5
267 - New major release
268 - Changes to support 4.0.5 
269
270 * Wed Jan 11 2007 Iain Lea <iain@bricbrac.de> 3.11.0-0
271 - fixed spec file to build correctly on fedora core
272 - added improved init.d script to work with chkconfig
273 - added %post and %postun to call chkconfig automatically
274
275 * Sun Jul 09 2006 Florian octo Forster <octo@verplant.org> 3.10.0-1
276 - New upstream version
277
278 * Tue Jun 25 2006 Florian octo Forster <octo@verplant.org> 3.9.4-1
279 - New upstream version
280
281 * Tue Jun 01 2006 Florian octo Forster <octo@verplant.org> 3.9.3-1
282 - New upstream version
283
284 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.9.2-1
285 - New upstream version
286
287 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.8.5-1
288 - New upstream version
289
290 * Fri Apr 21 2006 Florian octo Forster <octo@verplant.org> 3.9.1-1
291 - New upstream version
292
293 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
294 - New upstream version
295 - Added the `apache' package.
296
297 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
298 - New upstream version
299
300 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
301 - New upstream version
302
303 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
304 - New upstream version
305
306 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
307 - Include `tape.so' so the build doesn't terminate because of missing files..
308 - New upstream version
309
310 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
311 - New upstream version
312
313 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
314 - New upstream version
315 - Removed the extra `hddtemp' package
316
317 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
318 - New upstream version
319
320 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
321 - New upstream version
322
323 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
324 - New upstream version
325 - Added config file, `collectd.conf(5)', `df.so'
326 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
327
328 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
329 - New upstream version
330
331 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
332 - New upstream version
333
334 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
335 - New upstream version
336
337 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
338 - New upstream version
339 - Added statement to remove the `*.la' files. This fixes a problem when
340   `Unpackaged files terminate build' is in effect.
341 - Added `processes.so*' to the main package
342
343 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
344 - New upstream version
345 - Added package `collectd-hddtemp'
346
347 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
348 - New upstream version
349 - Split the package into `collectd' and `collectd-sensors'
350
351 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
352 - New upstream version
353
354 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
355 - New upstream version
356
357 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
358 - New upstream version
359
360 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
361 - New upstream version
362
363 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
364 - New upstream version
365
366 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
367 - New upstream version
368
369 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
370 - New upstream version
371
372 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
373 - New upstream version
374
375 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
376 - Built on RedHat 7.3