No need to edit collectd.conf anymore.
[collectd.git] / contrib / redhat / collectd.spec
1 %global _hardened_build 1
2
3 Summary:        Statistics collection daemon for filling RRD files
4 Name:           collectd
5 Version:        5.1.0
6 Release:        3%{?dist}
7 URL:            http://collectd.org
8 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
9 License:        GPLv2
10 Group:          System Environment/Daemons
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12 BuildRequires:  curl-devel, libgcrypt-devel, libxml2-devel, libstatgrab-devel
13 Vendor:         collectd development team <collectd@verplant.org>
14
15 Requires(post):         chkconfig
16 Requires(preun):        chkconfig, initscripts
17 Requires(postun):       initscripts
18
19 %description
20 collectd is a small daemon which collects system information periodically and
21 provides mechanisms to monitor and store the values in a variety of ways. It
22 is written in C for performance. Since the daemon doesn't need to start up
23 every time it wants to update the values it's very fast and easy on the
24 system. Also, the statistics are very fine grained since the files are updated
25 every 10 seconds.
26
27 %package amqp
28 Summary:        AMQP plugin for collectd
29 Group:          System Environment/Daemons
30 Requires:       %{name}%{?_isa} = %{version}-%{release}
31 BuildRequires:  librabbitmq-devel
32 %description amqp
33 The AMQP plugin transmits or receives values collected by collectd via the
34 Advanced Message Queuing Protocol (AMQP).
35
36 %package apache
37 Summary:        Apache plugin for collectd
38 Group:          System Environment/Daemons
39 Requires:       %{name}%{?_isa} = %{version}-%{release}
40 %description apache
41 This plugin collects data provided by Apache's `mod_status'.
42
43 %package ascent
44 Summary:        Ascent plugin for collectd
45 Group:          System Environment/Daemons
46 Requires:       %{name}%{?_isa} = %{version}-%{release}
47 %description ascent
48 The Ascent plugin reads and parses the statistics page of Ascent, a free and
49 open-source server software for the game World of Warcraft by Blizzard
50 Entertainment.
51
52 %package bind
53 Summary:        Bind plugin for collectd
54 Group:          System Environment/Daemons
55 Requires:       %{name}%{?_isa} = %{version}-%{release}
56 %description bind
57 The BIND plugin retrieves this information that's encoded in XML and provided
58 via HTTP and submits the values to collectd.
59
60 %package curl
61 Summary:        Curl plugin for collectd
62 Group:          System Environment/Daemons
63 Requires:       %{name}%{?_isa} = %{version}-%{release}
64 %description curl
65 The cURL plugin uses libcurl to read files and then parses them according to
66 the configuration.
67
68 %package curl_json
69 Summary:        Curl_json plugin for collectd
70 Group:          System Environment/Daemons
71 Requires:       %{name}%{?_isa} = %{version}-%{release}, curl, yajl
72 Buildrequires:  yajl-devel
73 %description curl_json
74 The cURL-JSON plugin queries JavaScript Object Notation (JSON) data using the
75 cURL library and parses it according to the user's configuration.
76
77 %package curl_xml
78 Summary:        Curl_xml plugin for collectd
79 Group:          System Environment/Daemons
80 Requires:       %{name}%{?_isa} = %{version}-%{release}
81 %description curl_xml
82 The cURL-XML plugin reads files using libcurl and parses it as Extensible
83 Markup Language (XML).
84
85 %package dbi
86 Summary:        DBI plugin for collectd
87 Group:          System Environment/Daemons
88 Requires:       %{name}%{?_isa} = %{version}-%{release}
89 Buildrequires:  libdbi-devel
90 %description dbi
91 The DBI plugin uses libdbi, a database abstraction library, to execute SQL
92 statements on a database and read back the result.
93
94 %package dns
95 Summary:        DNS plugin for collectd
96 Group:          System Environment/Daemons
97 Requires:       %{name}%{?_isa} = %{version}-%{release}
98 Buildrequires:  libpcap-devel
99 %description dns
100 The DNS plugin has a similar functionality to dnstop: It uses libpcap to get a
101 copy of all traffic from/to port UDP/53 (that's the DNS port), interprets the
102 packets and collects statistics of your DNS traffic.
103
104 %package email
105 Summary:        Email plugin for collectd
106 Group:          System Environment/Daemons
107 Requires:       %{name}%{?_isa} = %{version}-%{release}, spamassassin
108 %description email
109 This plugin collects data provided by spamassassin.
110
111 %package gmond
112 Summary:        Gmond plugin for collectd
113 Group:          System Environment/Daemons
114 Requires:       %{name}%{?_isa} = %{version}-%{release}
115 BuildRequires:  ganglia-devel
116 %description gmond
117 The gmond plugin subscribes to a Multicast group to receive data from gmond,
118 the client daemon of the Ganglia project.
119
120 %package hddtemp
121 Summary:        Hddtemp plugin for collectd
122 Group:          System Environment/Daemons
123 Requires:       %{name}%{?_isa} = %{version}-%{release}, hddtemp
124 %description hddtemp
125 The HDDTemp plugin collects the temperature of hard disks. The temperatures are
126 provided via SMART and queried by the external hddtemp daemon.
127
128 %package ipmi
129 Summary:        IPMI plugin for collectd
130 Group:          System Environment/Daemons
131 Requires:       %{name}%{?_isa} = %{version}-%{release}
132 BuildRequires:  OpenIPMI-devel
133 %description ipmi
134 The IPMI plugin uses the OpenIPMI library to read hardware sensors from servers
135 using the Intelligent Platform Management Interface (IPMI).
136
137 %package iptables
138 Summary:        IPtables plugin for collectd
139 Group:          System Environment/Daemons
140 Requires:       %{name}%{?_isa} = %{version}-%{release}
141 BuildRequires:  iptables-devel
142 %description iptables
143 The IP-Tables plugin can gather statistics from your ip_tables based packet
144 filter (aka. firewall) for both the IPv4 and the IPv6 protocol. It can collect
145 the byte- and packet-counters of selected rules and submit them to collectd.
146
147 %package java
148 Summary:        Java plugin for collectd
149 Group:          System Environment/Daemons
150 Requires:       %{name}%{?_isa} = %{version}-%{release}
151 BuildRequires:  java-devel, jpackage-utils
152 Requires:       java, jpackage-utils
153 %description java
154 This plugin for collectd allows plugins to be written in Java and executed
155 in an embedded JVM.
156
157 %package libvirt
158 Summary:        Libvirt plugin for collectd
159 Group:          System Environment/Daemons
160 Requires:       %{name}%{?_isa} = %{version}-%{release}
161 BuildRequires:  libvirt-devel
162 %description libvirt
163 This plugin collects information from virtualized guests.
164
165 %package memcachec
166 Summary:        Memcachec plugin for collectd
167 Group:          System Environment/Daemons
168 Requires:       %{name}%{?_isa} = %{version}-%{release}
169 BuildRequires:  libmemcached-devel
170 %description memcachec
171 The Memcachec plugin uses libmemcached to read statistics from a Memcached
172 instance. Note that another plugin, named `memcached', exists and does a
173 similar job, without requiring the installation of libmemcached.
174
175 %package mysql
176 Summary:        MySQL plugin for collectd
177 Group:          System Environment/Daemons
178 Requires:       %{name}%{?_isa} = %{version}-%{release}
179 BuildRequires:  mysql-devel
180 %description mysql
181 MySQL querying plugin. This plugin provides data of issued commands, called
182 handlers and database traffic.
183
184 %package nginx
185 Summary:        Nginx plugin for collectd
186 Group:          System Environment/Daemons
187 Requires:       %{name}%{?_isa} = %{version}-%{release}
188 %description nginx
189 This plugin gets data provided by nginx.
190
191 %package notify_desktop
192 Summary:        Notify_desktop plugin for collectd
193 Group:          System Environment/Daemons
194 Requires:       %{name}%{?_isa} = %{version}-%{release}
195 BuildRequires:  libnotify-devel
196 %description notify_desktop
197 The Notify Desktop plugin uses libnotify to display notifications to the user
198 via the desktop notification specification, i. e. on an X display.
199
200 %package notify_email
201 Summary:        Notify_email plugin for collectd
202 Group:          System Environment/Daemons
203 Requires:       %{name}%{?_isa} = %{version}-%{release}
204 BuildRequires:  libesmtp-devel
205 %description notify_email
206 The Notify Email plugin uses libESMTP to send notifications to a configured
207 email address.
208
209 %package nut
210 Summary:        Nut plugin for collectd
211 Group:          System Environment/Daemons
212 Requires:       %{name}%{?_isa} = %{version}-%{release}
213 BuildRequires:  nut-devel
214 %description nut
215 This plugin for collectd provides Network UPS Tools support.
216
217 %package perl
218 Summary:        Perl plugin for collectd
219 Group:          System Environment/Daemons
220 Requires:       %{name}%{?_isa} = %{version}-%{release}
221 Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
222 BuildRequires:  perl-ExtUtils-Embed
223 %description perl
224 The Perl plugin embeds a Perl interpreter into collectd and exposes the
225 application programming interface (API) to Perl-scripts.
226
227 %package pinba
228 Summary:        Pinba plugin for collectd
229 Group:          System Environment/Daemons
230 Requires:       %{name}%{?_isa} = %{version}-%{release}
231 BuildRequires:  protobuf-c-devel
232 %description pinba
233 The Pinba plugin receives and dispatches timing values from Pinba, a profiling
234 extension for PHP.
235
236 %package ping
237 Summary:        Ping plugin for collectd
238 Group:          System Environment/Daemons
239 Requires:       %{name}%{?_isa} = %{version}-%{release}
240 BuildRequires:  liboping-devel
241 %description ping
242 The Ping plugin measures network latency using ICMP “echo requests”, usually
243 known as “ping”.
244
245 %package postgresql
246 Summary:        PostgreSQL plugin for collectd
247 Group:          System Environment/Daemons
248 Requires:       %{name}%{?_isa} = %{version}-%{release}
249 BuildRequires:  postgresql-devel
250 %description postgresql
251 The PostgreSQL plugin connects to and executes SQL statements on a PostgreSQL
252 database.
253
254 %package python
255 Summary:        Python plugin for collectd
256 Group:          System Environment/Daemons
257 Requires:       %{name}%{?_isa} = %{version}-%{release}
258 BuildRequires:  python-devel
259 %description python
260 The Python plugin embeds a Python interpreter into collectd and exposes the
261 application programming interface (API) to Python-scripts.
262
263 %package rrdtool
264 Summary:        RRDtool plugin for collectd
265 Group:          System Environment/Daemons
266 Requires:       %{name}%{?_isa} = %{version}-%{release}
267 BuildRequires:  rrdtool-devel
268 %description rrdtool
269 The RRDtool plugin writes values to RRD-files using librrd.
270
271 %package sensors
272 Summary:        Sensors plugin for collectd
273 Group:          System Environment/Daemons
274 Requires:       %{name}%{?_isa} = %{version}-%{release}
275 BuildRequires:  lm_sensors-devel
276 %description sensors
277 This plugin for collectd provides querying of sensors supported by lm_sensors.
278
279 %package snmp
280 Summary:        SNMP plugin for collectd
281 Group:          System Environment/Daemons
282 Requires:       %{name}%{?_isa} = %{version}-%{release}
283 BuildRequires:  net-snmp-devel
284 %description snmp
285 This plugin for collectd allows querying of network equipment using SNMP.
286
287 %package varnish
288 Summary:        Varnish plugin for collectd
289 Group:          System Environment/Daemons
290 Requires:       %{name}%{?_isa} = %{version}-%{release}
291 BuildRequires:  varnish-libs-devel
292 %description varnish
293 The Varnish plugin collects information about Varnish, an HTTP accelerator.
294
295 %package write_http
296 Summary:        Write-HTTP plugin for collectd
297 Group:          System Environment/Daemons
298 Requires:       %{name}%{?_isa} = %{version}-%{release}
299 %description write_http
300 The Write-HTTP plugin sends the values collected by collectd to a web-server
301 using HTTP POST requests.
302
303 %package contrib
304 Summary:        Contrib files for collectd
305 Group:          System Environment/Daemons
306 Requires:       %{name}%{?_isa} = %{version}-%{release}
307 %description contrib
308 All the files found under contrib/ in the source tree are bundled in this
309 package.
310
311 %package -n libcollectdclient
312 Summary:        Collectd client library
313 %description -n libcollectdclient
314 Collectd client library
315
316 %package -n libcollectdclient-devel
317 Summary:        Development files for libcollectdclient
318 Requires:       pkgconfig
319 Requires:       libcollectdclient%{?_isa} = %{version}-%{release}
320 %description -n libcollectdclient-devel
321 Development files for libcollectdclient
322
323
324 %prep
325 %setup -q
326
327
328 %build
329 %configure CFLAGS="%{optflags} -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'" \
330         --disable-static \
331         --with-java=%{java_home}/ \
332         --with-perl-bindings=INSTALLDIRS=vendor
333
334 %{__make} %{?_smp_mflags}
335
336
337 %install
338 rm -rf %{buildroot}
339 %{__make} install DESTDIR=%{buildroot}
340 %{__install} -Dp -m 0755 contrib/redhat/init.d-collectd %{buildroot}%{_initrddir}/collectd
341 %{__install} -Dp -m0644 src/collectd.conf %{buildroot}%{_sysconfdir}/collectd.conf
342 %{__install} -d %{buildroot}%{sharedstatedir}/collectd/
343 %{__install} -d %{buildroot}%{_sysconfdir}/collectd.d/
344
345 ### Clean up docs
346 find contrib/ -type f -exec %{__chmod} a-x {} \;
347 # *.la files shouldn't be distributed.
348 rm -f %{buildroot}/%{_libdir}/{collectd/,}*.la
349
350 # Move the Perl examples to a separate directory.
351 mkdir perl-examples
352 find contrib -name '*.p[lm]' -exec mv {} perl-examples/ \;
353
354 # Remove Perl hidden .packlist files.
355 find %{buildroot} -type f -name .packlist -delete
356 # Remove Perl temporary file perllocal.pod
357 find %{buildroot} -type f -name perllocal.pod -delete
358
359
360 %clean
361 rm -rf %{buildroot}
362
363 %post
364 /sbin/chkconfig --add collectd
365
366 %preun
367 if [ $1 -eq 0 ]; then
368         /sbin/service collectd stop &>/dev/null
369         /sbin/chkconfig --del collectd
370 fi
371
372 %postun
373 if [ $1 -ge 1 ]; then
374         /sbin/service collectd condrestart &>/dev/null || :
375 fi
376
377 %post -n libcollectdclient -p /sbin/ldconfig
378 %postun -n libcollectdclient -p /sbin/ldconfig
379
380
381 %files
382 %doc AUTHORS COPYING ChangeLog README
383 %config(noreplace) %{_sysconfdir}/collectd.conf
384 %{_initrddir}/collectd
385 %{_sbindir}/collectd
386 %{_bindir}/collectd-nagios
387 %{_bindir}/collectdctl
388 %{_sbindir}/collectdmon
389 %{_datadir}/collectd/
390 %{_sharedstatedir}/collectd
391 %{_mandir}/man1/collectd-nagios.1.gz
392 %{_mandir}/man1/collectd.1.gz
393 %{_mandir}/man1/collectdctl.1.gz
394 %{_mandir}/man1/collectdmon.1.gz
395 %{_mandir}/man5/collectd-email.5.gz
396 %{_mandir}/man5/collectd-exec.5.gz
397 %{_mandir}/man5/collectd-threshold.5.gz
398 %{_mandir}/man5/collectd-unixsock.5.gz
399 %{_mandir}/man5/collectd.conf.5.gz
400 %{_mandir}/man5/types.db.5.gz
401
402 # all plugins bundled with the main collectd package
403 %{_libdir}/%{name}/apcups.so
404 %{_libdir}/%{name}/battery.so
405 %{_libdir}/%{name}/conntrack.so
406 %{_libdir}/%{name}/contextswitch.so
407 %{_libdir}/%{name}/cpufreq.so
408 %{_libdir}/%{name}/cpu.so
409 %{_libdir}/%{name}/csv.so
410 %{_libdir}/%{name}/df.so
411 %{_libdir}/%{name}/disk.so
412 %{_libdir}/%{name}/ethstat.so
413 %{_libdir}/%{name}/entropy.so
414 %{_libdir}/%{name}/email.so
415 %{_libdir}/%{name}/exec.so
416 %{_libdir}/%{name}/filecount.so
417 %{_libdir}/%{name}/fscache.so
418 %{_libdir}/%{name}/interface.so
419 %{_libdir}/%{name}/iptables.so
420 %{_libdir}/%{name}/ipvs.so
421 %{_libdir}/%{name}/irq.so
422 %{_libdir}/%{name}/load.so
423 %{_libdir}/%{name}/logfile.so
424 %{_libdir}/%{name}/madwifi.so
425 %{_libdir}/%{name}/match_empty_counter.so
426 %{_libdir}/%{name}/match_hashed.so
427 %{_libdir}/%{name}/match_regex.so
428 %{_libdir}/%{name}/match_timediff.so
429 %{_libdir}/%{name}/match_value.so
430 %{_libdir}/%{name}/mbmon.so
431 %{_libdir}/%{name}/md.so
432 %{_libdir}/%{name}/memcached.so
433 %{_libdir}/%{name}/memory.so
434 %{_libdir}/%{name}/multimeter.so
435 %{_libdir}/%{name}/network.so
436 %{_libdir}/%{name}/nfs.so
437 %{_libdir}/%{name}/ntpd.so
438 %{_libdir}/%{name}/numa.so
439 %{_libdir}/%{name}/openvpn.so
440 %{_libdir}/%{name}/olsrd.so
441 %{_libdir}/%{name}/powerdns.so
442 %{_libdir}/%{name}/processes.so
443 %{_libdir}/%{name}/protocols.so
444 %{_libdir}/%{name}/serial.so
445 %{_libdir}/%{name}/swap.so
446 %{_libdir}/%{name}/syslog.so
447 %{_libdir}/%{name}/table.so
448 %{_libdir}/%{name}/tail.so
449 %{_libdir}/%{name}/target_notification.so
450 %{_libdir}/%{name}/target_replace.so
451 %{_libdir}/%{name}/target_scale.so
452 %{_libdir}/%{name}/target_set.so
453 %{_libdir}/%{name}/target_v5upgrade.so
454 %{_libdir}/%{name}/tcpconns.so
455 %{_libdir}/%{name}/teamspeak2.so
456 %{_libdir}/%{name}/ted.so
457 %{_libdir}/%{name}/thermal.so
458 %{_libdir}/%{name}/threshold.so
459 %{_libdir}/%{name}/unixsock.so
460 %{_libdir}/%{name}/uptime.so
461 %{_libdir}/%{name}/users.so
462 %{_libdir}/%{name}/uuid.so
463 %{_libdir}/%{name}/vmem.so
464 %{_libdir}/%{name}/vserver.so
465 %{_libdir}/%{name}/wireless.so
466 %{_libdir}/%{name}/write_graphite.so
467
468 # All plugins not built because of dependencies on libraries not available in
469 # RHEL or EPEL:
470 # plugin modbus disabled, requires libmodbus
471 # plugin netlink disabled, requires libnetlink.h
472 # plugin numa disabled, requires libnetapp
473 # plugin onewire disabled, requires libowfs
474 # plugin oracle disabled, requires Oracle
475 # plugin redis disabled, requires credis
476 # plugin routeros disabled, requires librouteros
477 # plugin rrdcached disabled, requires rrdtool >= 1.4
478 # plugin tokyotyrant disabled, requires tcrdb.h
479 # plugin write_mongodb disabled, requires libmongoc
480 # plugin write_redis disabled, requires credis
481 # plugin xmms disabled, requires xmms
482
483
484 %files -n libcollectdclient-devel
485 %{_includedir}/collectd/client.h
486 %{_includedir}/collectd/lcc_features.h
487 %{_libdir}/libcollectdclient.so
488 %{_libdir}/pkgconfig/libcollectdclient.pc
489
490 %files -n libcollectdclient
491 %{_libdir}/libcollectdclient.so.*
492
493
494 %files amqp
495 %{_libdir}/%{name}/amqp.so
496
497 %files apache
498 %{_libdir}/%{name}/apache.so
499
500 %files ascent
501 %{_libdir}/%{name}/ascent.so
502
503 %files bind
504 %{_libdir}/%{name}/bind.so
505
506 %files curl
507 %{_libdir}/%{name}/curl.so
508
509 %files curl_json
510 %{_libdir}/%{name}/curl_json.so
511
512 %files curl_xml
513 %{_libdir}/%{name}/curl_xml.so
514
515 %files dns
516 %{_libdir}/%{name}/dns.so
517
518 %files dbi
519 %{_libdir}/%{name}/dbi.so
520
521 %files email
522 %{_libdir}/%{name}/email.so
523
524 %files gmond
525 %{_libdir}/%{name}/gmond.so
526
527 %files hddtemp
528 %{_libdir}/%{name}/hddtemp.so
529
530 %files ipmi
531 %{_libdir}/%{name}/ipmi.so
532
533 %files iptables
534 %{_libdir}/%{name}/iptables.so
535
536 %files java
537 %{_mandir}/man5/collectd-java.5.gz
538 %{_datarootdir}/collectd/java/collectd-api.jar
539 %{_datarootdir}/collectd/java/generic-jmx.jar
540 %{_libdir}/%{name}/java.so
541
542 %files libvirt
543 %{_libdir}/%{name}/libvirt.so
544
545 %files memcachec
546 %{_libdir}/%{name}/memcachec.so
547
548 %files mysql
549 %{_libdir}/%{name}/mysql.so
550
551 %files nginx
552 %{_libdir}/%{name}/nginx.so
553
554 %files notify_desktop
555 %{_libdir}/%{name}/notify_desktop.so
556
557 %files notify_email
558 %{_libdir}/%{name}/notify_email.so
559
560 %files nut
561 %{_libdir}/%{name}/nut.so
562
563 %files perl
564 %doc perl-examples/*
565 %{perl_vendorlib}/Collectd.pm
566 %{perl_vendorlib}/Collectd/
567 %{_mandir}/man3/Collectd::Unixsock.3pm.gz
568 %{_mandir}/man5/collectd-perl.5.gz
569 %{_libdir}/%{name}/perl.so
570
571 %files pinba
572 %{_libdir}/%{name}/pinba.so
573
574 %files ping
575 %{_libdir}/%{name}/ping.so
576
577 %files postgresql
578 %{_datarootdir}/collectd/postgresql_default.conf
579 %{_libdir}/%{name}/postgresql.so
580
581 %files python
582 %{_mandir}/man5/collectd-python.5.gz
583 %{_libdir}/%{name}/python.so
584
585 %files rrdtool
586 %{_libdir}/%{name}/rrdtool.so
587
588 %files sensors
589 %{_libdir}/%{name}/sensors.so
590
591 %files snmp
592 %{_mandir}/man5/collectd-snmp.5.gz
593 %{_libdir}/%{name}/snmp.so
594
595 %files varnish
596 %{_libdir}/%{name}/varnish.so
597
598 %files write_http
599 %{_libdir}/%{name}/write_http.so
600
601 %files contrib
602 %doc contrib/
603
604 %changelog
605 * Sun Nov 18 2012 Ruben Kerkhof <ruben@tilaa.nl> 5.1.0-3
606 - Follow Fedora Packaging Guidelines in java subpackage
607
608 * Sat Nov 17 2012 Ruben Kerkhof <ruben@tilaa.nl> 5.1.0-2
609 - Move perl stuff to perl_vendorlib
610 - Replace hardcoded paths with macros
611 - Remove unneccesary Requires
612 - Removed .a and .la files
613 - Some other small cleanups
614
615 * Fri Nov 16 2012 Marc Fournier <marc.fournier@camptocamp.com> 5.1.0-1
616 - New upstream version
617 - Changes to support 5.1.0
618 - Enabled all buildable plugins based on libraries available on EL6 + EPEL
619 - All plugins requiring external libraries are now shipped in seperate
620   packages.
621 - No longer treat Java plugin as an exception, correctly set $JAVA_HOME during
622   the build process + ensure build deps are installed.
623 - Dropped per-plugin configuration files, as they tend to diverge from upstream
624   defaults.
625 - Moved perl stuff to /usr/share/perl5/
626 - Don't alter Interval and ReadThreads by default, let the user change this
627   himself.
628 - Initscript improvements:
629   * checks configuration before (re)starting, based on debian's initscript
630   * use /etc/sysconfig instdead of /etc/default
631   * include optional $ARGS in arguments passed to collectd.
632 - Drop collection.cgi from main package, as it's been obsoleted by collection3
633 - Moved contrib/ to its own package, to avoid cluttering the main package with
634   non-essential stuff.
635 - Replaced BuildPrereq by BuildRequires
636
637 * Tue Jan 03 2011 Monetate <jason.stelzer@monetate.com> 5.0.1
638 - New upstream version
639 - Changes to support 5.0.1
640
641 * Tue Jan 04 2010 Rackspace <stu.hood@rackspace.com> 4.9.0
642 - New upstream version
643 - Changes to support 4.9.0
644 - Added support for Java/GenericJMX plugin
645
646 * Mon Mar 17 2008 RightScale <support@rightscale.com> 4.3.1
647 - New upstream version
648 - Changes to support 4.3.1
649 - Added More Prereqs to support more plugins
650 - Added support for perl plugin
651
652 * Mon Aug 06 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.6
653 - New upstream version
654
655 * Wed Jul 25 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.5
656 - New major releas
657 - Changes to support 4.0.5
658
659 * Wed Jan 11 2007 Iain Lea <iain@bricbrac.de> 3.11.0-0
660 - fixed spec file to build correctly on fedora core
661 - added improved init.d script to work with chkconfig
662 - added %%post and %%postun to call chkconfig automatically
663
664 * Sun Jul 09 2006 Florian octo Forster <octo@verplant.org> 3.10.0-1
665 - New upstream version
666
667 * Tue Jun 25 2006 Florian octo Forster <octo@verplant.org> 3.9.4-1
668 - New upstream version
669
670 * Tue Jun 01 2006 Florian octo Forster <octo@verplant.org> 3.9.3-1
671 - New upstream version
672
673 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.9.2-1
674 - New upstream version
675
676 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.8.5-1
677 - New upstream version
678
679 * Fri Apr 21 2006 Florian octo Forster <octo@verplant.org> 3.9.1-1
680 - New upstream version
681
682 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
683 - New upstream version
684 - Added the `apache' package.
685
686 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
687 - New upstream version
688
689 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
690 - New upstream version
691
692 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
693 - New upstream version
694
695 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
696 - Include `tape.so' so the build doesn't terminate because of missing files..
697 - New upstream version
698
699 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
700 - New upstream version
701
702 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
703 - New upstream version
704 - Removed the extra `hddtemp' package
705
706 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
707 - New upstream version
708
709 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
710 - New upstream version
711
712 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
713 - New upstream version
714 - Added config file, `collectd.conf(5)', `df.so'
715 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
716
717 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
718 - New upstream version
719
720 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
721 - New upstream version
722
723 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
724 - New upstream version
725
726 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
727 - New upstream version
728 - Added statement to remove the `*.la' files. This fixes a problem when
729   `Unpackaged files terminate build' is in effect.
730 - Added `processes.so*' to the main package
731
732 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
733 - New upstream version
734 - Added package `collectd-hddtemp'
735
736 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
737 - New upstream version
738 - Split the package into `collectd' and `collectd-sensors'
739
740 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
741 - New upstream version
742
743 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
744 - New upstream version
745
746 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
747 - New upstream version
748
749 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
750 - New upstream version
751
752 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
753 - New upstream version
754
755 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
756 - New upstream version
757
758 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
759 - New upstream version
760
761 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
762 - New upstream version
763
764 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
765 - Built on RedHat 7.3