Cleanup redhat specfile
[collectd.git] / contrib / redhat / collectd.spec
1 %global _hardened_build 1
2
3 Summary:        Statistics collection daemon for filling RRD files
4 Name:           collectd
5 Version:        5.1.0
6 Release:        2%{?dist}
7 URL:            http://collectd.org
8 Source:         http://collectd.org/files/%{name}-%{version}.tar.gz
9 License:        GPLv2
10 Group:          System Environment/Daemons
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12 BuildRequires:  curl-devel, libgcrypt-devel, libxml2-devel, libstatgrab-devel
13 Vendor:         collectd development team <collectd@verplant.org>
14
15 Requires(post):         chkconfig
16 Requires(preun):        chkconfig, initscripts
17 Requires(postun):       initscripts
18
19 %description
20 collectd is a small daemon which collects system information periodically and
21 provides mechanisms to monitor and store the values in a variety of ways. It
22 is written in C for performance. Since the daemon doesn't need to start up
23 every time it wants to update the values it's very fast and easy on the
24 system. Also, the statistics are very fine grained since the files are updated
25 every 10 seconds.
26
27 %package amqp
28 Summary:        AMQP plugin for collectd
29 Group:          System Environment/Daemons
30 Requires:       %{name}%{?_isa} = %{version}-%{release}
31 BuildRequires:  librabbitmq-devel
32 %description amqp
33 The AMQP plugin transmits or receives values collected by collectd via the
34 Advanced Message Queuing Protocol (AMQP).
35
36 %package apache
37 Summary:        Apache plugin for collectd
38 Group:          System Environment/Daemons
39 Requires:       %{name}%{?_isa} = %{version}-%{release}
40 %description apache
41 This plugin collects data provided by Apache's `mod_status'.
42
43 %package ascent
44 Summary:        Ascent plugin for collectd
45 Group:          System Environment/Daemons
46 Requires:       %{name}%{?_isa} = %{version}-%{release}
47 %description ascent
48 The Ascent plugin reads and parses the statistics page of Ascent, a free and
49 open-source server software for the game World of Warcraft by Blizzard
50 Entertainment.
51
52 %package bind
53 Summary:        Bind plugin for collectd
54 Group:          System Environment/Daemons
55 Requires:       %{name}%{?_isa} = %{version}-%{release}
56 %description bind
57 The BIND plugin retrieves this information that's encoded in XML and provided
58 via HTTP and submits the values to collectd.
59
60 %package curl
61 Summary:        Curl plugin for collectd
62 Group:          System Environment/Daemons
63 Requires:       %{name}%{?_isa} = %{version}-%{release}
64 %description curl
65 The cURL plugin uses libcurl to read files and then parses them according to
66 the configuration.
67
68 %package curl_json
69 Summary:        Curl_json plugin for collectd
70 Group:          System Environment/Daemons
71 Requires:       %{name}%{?_isa} = %{version}-%{release}, curl, yajl
72 Buildrequires:  yajl-devel
73 %description curl_json
74 The cURL-JSON plugin queries JavaScript Object Notation (JSON) data using the
75 cURL library and parses it according to the user's configuration.
76
77 %package curl_xml
78 Summary:        Curl_xml plugin for collectd
79 Group:          System Environment/Daemons
80 Requires:       %{name}%{?_isa} = %{version}-%{release}
81 %description curl_xml
82 The cURL-XML plugin reads files using libcurl and parses it as Extensible
83 Markup Language (XML).
84
85 %package dbi
86 Summary:        DBI plugin for collectd
87 Group:          System Environment/Daemons
88 Requires:       %{name}%{?_isa} = %{version}-%{release}
89 Buildrequires:  libdbi-devel
90 %description dbi
91 The DBI plugin uses libdbi, a database abstraction library, to execute SQL
92 statements on a database and read back the result.
93
94 %package dns
95 Summary:        DNS plugin for collectd
96 Group:          System Environment/Daemons
97 Requires:       %{name}%{?_isa} = %{version}-%{release}
98 Buildrequires:  libpcap-devel
99 %description dns
100 The DNS plugin has a similar functionality to dnstop: It uses libpcap to get a
101 copy of all traffic from/to port UDP/53 (that's the DNS port), interprets the
102 packets and collects statistics of your DNS traffic.
103
104 %package email
105 Summary:        Email plugin for collectd
106 Group:          System Environment/Daemons
107 Requires:       %{name}%{?_isa} = %{version}-%{release}, spamassassin
108 %description email
109 This plugin collects data provided by spamassassin.
110
111 %package gmond
112 Summary:        Gmond plugin for collectd
113 Group:          System Environment/Daemons
114 Requires:       %{name}%{?_isa} = %{version}-%{release}
115 BuildRequires:  ganglia-devel
116 %description gmond
117 The gmond plugin subscribes to a Multicast group to receive data from gmond,
118 the client daemon of the Ganglia project.
119
120 %package hddtemp
121 Summary:        Hddtemp plugin for collectd
122 Group:          System Environment/Daemons
123 Requires:       %{name}%{?_isa} = %{version}-%{release}, hddtemp
124 %description hddtemp
125 The HDDTemp plugin collects the temperature of hard disks. The temperatures are
126 provided via SMART and queried by the external hddtemp daemon.
127
128 %package ipmi
129 Summary:        IPMI plugin for collectd
130 Group:          System Environment/Daemons
131 Requires:       %{name}%{?_isa} = %{version}-%{release}
132 BuildRequires:  OpenIPMI-devel
133 %description ipmi
134 The IPMI plugin uses the OpenIPMI library to read hardware sensors from servers
135 using the Intelligent Platform Management Interface (IPMI).
136
137 %package iptables
138 Summary:        IPtables plugin for collectd
139 Group:          System Environment/Daemons
140 Requires:       %{name}%{?_isa} = %{version}-%{release}
141 BuildRequires:  iptables-devel
142 %description iptables
143 The IP-Tables plugin can gather statistics from your ip_tables based packet
144 filter (aka. firewall) for both the IPv4 and the IPv6 protocol. It can collect
145 the byte- and packet-counters of selected rules and submit them to collectd.
146
147 %package java
148 Summary:        Java plugin for collectd
149 Group:          System Environment/Daemons
150 Requires:       %{name}%{?_isa} = %{version}-%{release}
151 BuildRequires:  java-1.7.0-openjdk-devel
152 %description java
153 This plugin for collectd allows plugins to be written in Java and executed
154 in an embedded JVM.
155
156 %package libvirt
157 Summary:        Libvirt plugin for collectd
158 Group:          System Environment/Daemons
159 Requires:       %{name}%{?_isa} = %{version}-%{release}
160 BuildRequires:  libvirt-devel
161 %description libvirt
162 This plugin collects information from virtualized guests.
163
164 %package memcachec
165 Summary:        Memcachec plugin for collectd
166 Group:          System Environment/Daemons
167 Requires:       %{name}%{?_isa} = %{version}-%{release}
168 BuildRequires:  libmemcached-devel
169 %description memcachec
170 The Memcachec plugin uses libmemcached to read statistics from a Memcached
171 instance. Note that another plugin, named `memcached', exists and does a
172 similar job, without requiring the installation of libmemcached.
173
174 %package mysql
175 Summary:        MySQL plugin for collectd
176 Group:          System Environment/Daemons
177 Requires:       %{name}%{?_isa} = %{version}-%{release}
178 BuildRequires:  mysql-devel
179 %description mysql
180 MySQL querying plugin. This plugin provides data of issued commands, called
181 handlers and database traffic.
182
183 %package nginx
184 Summary:        Nginx plugin for collectd
185 Group:          System Environment/Daemons
186 Requires:       %{name}%{?_isa} = %{version}-%{release}
187 %description nginx
188 This plugin gets data provided by nginx.
189
190 %package notify_desktop
191 Summary:        Notify_desktop plugin for collectd
192 Group:          System Environment/Daemons
193 Requires:       %{name}%{?_isa} = %{version}-%{release}
194 BuildRequires:  libnotify-devel
195 %description notify_desktop
196 The Notify Desktop plugin uses libnotify to display notifications to the user
197 via the desktop notification specification, i. e. on an X display.
198
199 %package notify_email
200 Summary:        Notify_email plugin for collectd
201 Group:          System Environment/Daemons
202 Requires:       %{name}%{?_isa} = %{version}-%{release}
203 BuildRequires:  libesmtp-devel
204 %description notify_email
205 The Notify Email plugin uses libESMTP to send notifications to a configured
206 email address.
207
208 %package nut
209 Summary:        Nut plugin for collectd
210 Group:          System Environment/Daemons
211 Requires:       %{name}%{?_isa} = %{version}-%{release}
212 BuildRequires:  nut-devel
213 %description nut
214 This plugin for collectd provides Network UPS Tools support.
215
216 %package perl
217 Summary:        Perl plugin for collectd
218 Group:          System Environment/Daemons
219 Requires:       %{name}%{?_isa} = %{version}-%{release}
220 Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
221 BuildRequires:  perl-ExtUtils-Embed
222 %description perl
223 The Perl plugin embeds a Perl interpreter into collectd and exposes the
224 application programming interface (API) to Perl-scripts.
225
226 %package pinba
227 Summary:        Pinba plugin for collectd
228 Group:          System Environment/Daemons
229 Requires:       %{name}%{?_isa} = %{version}-%{release}
230 BuildRequires:  protobuf-c-devel
231 %description pinba
232 The Pinba plugin receives and dispatches timing values from Pinba, a profiling
233 extension for PHP.
234
235 %package ping
236 Summary:        Ping plugin for collectd
237 Group:          System Environment/Daemons
238 Requires:       %{name}%{?_isa} = %{version}-%{release}
239 BuildRequires:  liboping-devel
240 %description ping
241 The Ping plugin measures network latency using ICMP “echo requests”, usually
242 known as “ping”.
243
244 %package postgresql
245 Summary:        PostgreSQL plugin for collectd
246 Group:          System Environment/Daemons
247 Requires:       %{name}%{?_isa} = %{version}-%{release}
248 BuildRequires:  postgresql-devel
249 %description postgresql
250 The PostgreSQL plugin connects to and executes SQL statements on a PostgreSQL
251 database.
252
253 %package python
254 Summary:        Python plugin for collectd
255 Group:          System Environment/Daemons
256 Requires:       %{name}%{?_isa} = %{version}-%{release}
257 BuildRequires:  python-devel
258 %description python
259 The Python plugin embeds a Python interpreter into collectd and exposes the
260 application programming interface (API) to Python-scripts.
261
262 %package rrdtool
263 Summary:        RRDtool plugin for collectd
264 Group:          System Environment/Daemons
265 Requires:       %{name}%{?_isa} = %{version}-%{release}
266 BuildRequires:  rrdtool-devel
267 %description rrdtool
268 The RRDtool plugin writes values to RRD-files using librrd.
269
270 %package sensors
271 Summary:        Sensors plugin for collectd
272 Group:          System Environment/Daemons
273 Requires:       %{name}%{?_isa} = %{version}-%{release}
274 BuildRequires:  lm_sensors-devel
275 %description sensors
276 This plugin for collectd provides querying of sensors supported by lm_sensors.
277
278 %package snmp
279 Summary:        SNMP plugin for collectd
280 Group:          System Environment/Daemons
281 Requires:       %{name}%{?_isa} = %{version}-%{release}
282 BuildRequires:  net-snmp-devel
283 %description snmp
284 This plugin for collectd allows querying of network equipment using SNMP.
285
286 %package varnish
287 Summary:        Varnish plugin for collectd
288 Group:          System Environment/Daemons
289 Requires:       %{name}%{?_isa} = %{version}-%{release}
290 BuildRequires:  varnish-libs-devel
291 %description varnish
292 The Varnish plugin collects information about Varnish, an HTTP accelerator.
293
294 %package write_http
295 Summary:        Write-HTTP plugin for collectd
296 Group:          System Environment/Daemons
297 Requires:       %{name}%{?_isa} = %{version}-%{release}
298 %description write_http
299 The Write-HTTP plugin sends the values collected by collectd to a web-server
300 using HTTP POST requests.
301
302 %package contrib
303 Summary:        Contrib files for collectd
304 Group:          System Environment/Daemons
305 Requires:       %{name}%{?_isa} = %{version}-%{release}
306 %description contrib
307 All the files found under contrib/ in the source tree are bundled in this
308 package.
309
310 %package -n libcollectdclient
311 Summary:        Collectd client library
312 %description -n libcollectdclient
313 Collectd client library
314
315 %package -n libcollectdclient-devel
316 Summary:        Development files for libcollectdclient
317 Requires:       pkgconfig
318 Requires:       libcollectdclient%{?_isa} = %{version}-%{release}
319 %description -n libcollectdclient-devel
320 Development files for libcollectdclient
321
322
323 %prep
324 %setup -q
325
326
327 %build
328 export JAVA_HOME="/usr"
329 %configure CFLAGS="%{optflags} -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'" \
330         --disable-static \
331         --disable-rrdcached \
332         --with-perl-bindings=INSTALLDIRS=vendor
333
334 %{__make} %{?_smp_mflags}
335
336
337 %install
338 rm -rf %{buildroot}
339 %{__make} install DESTDIR=%{buildroot}
340 %{__install} -Dp -m 0755 contrib/redhat/init.d-collectd %{buildroot}%{_initrddir}/collectd
341 %{__install} -Dp -m0644 src/collectd.conf %{buildroot}%{_sysconfdir}/collectd.conf
342 %{__install} -d %{buildroot}%{sharedstatedir}/collectd/
343 %{__install} -d %{buildroot}%{_sysconfdir}/collectd.d/
344
345 ### Clean up docs
346 find contrib/ -type f -exec %{__chmod} a-x {} \;
347 # *.la files shouldn't be distributed.
348 rm -f %{buildroot}/%{_libdir}/{collectd/,}*.la
349
350 # Move the Perl examples to a separate directory.
351 mkdir perl-examples
352 find contrib -name '*.p[lm]' -exec mv {} perl-examples/ \;
353
354 # Modify config for Red Hat based Distros
355 sed -i 's:#BaseDir *"/usr/var/lib/collectd":BaseDir "%{_sharedstatedir}/collectd":' %{buildroot}%{_sysconfdir}/collectd.conf
356 sed -i 's:#PIDFile *"/usr/var/run/collectd.pid":PIDFile "%{_localstatedir}/run/collectd.pid":' %{buildroot}%{_sysconfdir}/collectd.conf
357 sed -i 's:#PluginDir *"/usr/lib/collectd":PluginDir "%{_libdir}/collectd":' %{buildroot}%{_sysconfdir}/collectd.conf
358
359 # Remove Perl hidden .packlist files.
360 find %{buildroot} -type f -name .packlist -delete
361 # Remove Perl temporary file perllocal.pod
362 find %{buildroot} -type f -name perllocal.pod -delete
363
364
365 %clean
366 rm -rf %{buildroot}
367
368 %post
369 /sbin/chkconfig --add collectd
370
371 %preun
372 if [ $1 -eq 0 ]; then
373         /sbin/service collectd stop &>/dev/null
374         /sbin/chkconfig --del collectd
375 fi
376
377 %postun
378 if [ $1 -ge 1 ]; then
379         /sbin/service collectd condrestart &>/dev/null || :
380 fi
381
382 %post -n libcollectdclient -p /sbin/ldconfig
383 %postun -n libcollectdclient -p /sbin/ldconfig
384
385
386 %files
387 %doc AUTHORS COPYING ChangeLog README
388 %config(noreplace) %{_sysconfdir}/collectd.conf
389 %{_initrddir}/collectd
390 %{_sbindir}/collectd
391 %{_bindir}/collectd-nagios
392 %{_bindir}/collectdctl
393 %{_sbindir}/collectdmon
394 %{_datadir}/collectd/
395 %{_sharedstatedir}/collectd
396 %{_mandir}/man1/collectd-nagios.1.gz
397 %{_mandir}/man1/collectd.1.gz
398 %{_mandir}/man1/collectdctl.1.gz
399 %{_mandir}/man1/collectdmon.1.gz
400 %{_mandir}/man5/collectd-email.5.gz
401 %{_mandir}/man5/collectd-exec.5.gz
402 %{_mandir}/man5/collectd-threshold.5.gz
403 %{_mandir}/man5/collectd-unixsock.5.gz
404 %{_mandir}/man5/collectd.conf.5.gz
405 %{_mandir}/man5/types.db.5.gz
406
407 # all plugins bundled with the main collectd package
408 %{_libdir}/%{name}/apcups.so
409 %{_libdir}/%{name}/battery.so
410 %{_libdir}/%{name}/conntrack.so
411 %{_libdir}/%{name}/contextswitch.so
412 %{_libdir}/%{name}/cpufreq.so
413 %{_libdir}/%{name}/cpu.so
414 %{_libdir}/%{name}/csv.so
415 %{_libdir}/%{name}/df.so
416 %{_libdir}/%{name}/disk.so
417 %{_libdir}/%{name}/ethstat.so
418 %{_libdir}/%{name}/entropy.so
419 %{_libdir}/%{name}/email.so
420 %{_libdir}/%{name}/exec.so
421 %{_libdir}/%{name}/filecount.so
422 %{_libdir}/%{name}/fscache.so
423 %{_libdir}/%{name}/interface.so
424 %{_libdir}/%{name}/iptables.so
425 %{_libdir}/%{name}/ipvs.so
426 %{_libdir}/%{name}/irq.so
427 %{_libdir}/%{name}/load.so
428 %{_libdir}/%{name}/logfile.so
429 %{_libdir}/%{name}/madwifi.so
430 %{_libdir}/%{name}/match_empty_counter.so
431 %{_libdir}/%{name}/match_hashed.so
432 %{_libdir}/%{name}/match_regex.so
433 %{_libdir}/%{name}/match_timediff.so
434 %{_libdir}/%{name}/match_value.so
435 %{_libdir}/%{name}/mbmon.so
436 %{_libdir}/%{name}/md.so
437 %{_libdir}/%{name}/memcached.so
438 %{_libdir}/%{name}/memory.so
439 %{_libdir}/%{name}/multimeter.so
440 %{_libdir}/%{name}/network.so
441 %{_libdir}/%{name}/nfs.so
442 %{_libdir}/%{name}/ntpd.so
443 %{_libdir}/%{name}/numa.so
444 %{_libdir}/%{name}/openvpn.so
445 %{_libdir}/%{name}/olsrd.so
446 %{_libdir}/%{name}/powerdns.so
447 %{_libdir}/%{name}/processes.so
448 %{_libdir}/%{name}/protocols.so
449 %{_libdir}/%{name}/serial.so
450 %{_libdir}/%{name}/swap.so
451 %{_libdir}/%{name}/syslog.so
452 %{_libdir}/%{name}/table.so
453 %{_libdir}/%{name}/tail.so
454 %{_libdir}/%{name}/target_notification.so
455 %{_libdir}/%{name}/target_replace.so
456 %{_libdir}/%{name}/target_scale.so
457 %{_libdir}/%{name}/target_set.so
458 %{_libdir}/%{name}/target_v5upgrade.so
459 %{_libdir}/%{name}/tcpconns.so
460 %{_libdir}/%{name}/teamspeak2.so
461 %{_libdir}/%{name}/ted.so
462 %{_libdir}/%{name}/thermal.so
463 %{_libdir}/%{name}/threshold.so
464 %{_libdir}/%{name}/unixsock.so
465 %{_libdir}/%{name}/uptime.so
466 %{_libdir}/%{name}/users.so
467 %{_libdir}/%{name}/uuid.so
468 %{_libdir}/%{name}/vmem.so
469 %{_libdir}/%{name}/vserver.so
470 %{_libdir}/%{name}/wireless.so
471 %{_libdir}/%{name}/write_graphite.so
472
473 # All plugins not built because of dependencies on libraries not available in
474 # RHEL or EPEL:
475 # plugin modbus disabled, requires libmodbus
476 # plugin netlink disabled, requires libnetlink.h
477 # plugin numa disabled, requires libnetapp
478 # plugin onewire disabled, requires libowfs
479 # plugin oracle disabled, requires Oracle
480 # plugin redis disabled, requires credis
481 # plugin routeros disabled, requires librouteros
482 # plugin rrdcached disabled, requires rrdtool >= 1.4
483 # plugin tokyotyrant disabled, requires tcrdb.h
484 # plugin write_mongodb disabled, requires libmongoc
485 # plugin write_redis disabled, requires credis
486 # plugin xmms disabled, requires xmms
487
488
489 %files -n libcollectdclient-devel
490 %{_includedir}/collectd/client.h
491 %{_includedir}/collectd/lcc_features.h
492 %{_libdir}/libcollectdclient.so
493 %{_libdir}/pkgconfig/libcollectdclient.pc
494
495 %files -n libcollectdclient
496 %{_libdir}/libcollectdclient.so.*
497
498
499 %files amqp
500 %{_libdir}/%{name}/amqp.so
501
502 %files apache
503 %{_libdir}/%{name}/apache.so
504
505 %files ascent
506 %{_libdir}/%{name}/ascent.so
507
508 %files bind
509 %{_libdir}/%{name}/bind.so
510
511 %files curl
512 %{_libdir}/%{name}/curl.so
513
514 %files curl_json
515 %{_libdir}/%{name}/curl_json.so
516
517 %files curl_xml
518 %{_libdir}/%{name}/curl_xml.so
519
520 %files dns
521 %{_libdir}/%{name}/dns.so
522
523 %files dbi
524 %{_libdir}/%{name}/dbi.so
525
526 %files email
527 %{_libdir}/%{name}/email.so
528
529 %files gmond
530 %{_libdir}/%{name}/gmond.so
531
532 %files hddtemp
533 %{_libdir}/%{name}/hddtemp.so
534
535 %files ipmi
536 %{_libdir}/%{name}/ipmi.so
537
538 %files iptables
539 %{_libdir}/%{name}/iptables.so
540
541 %files java
542 %{_mandir}/man5/collectd-java.5.gz
543 %{_datarootdir}/collectd/java/collectd-api.jar
544 %{_datarootdir}/collectd/java/generic-jmx.jar
545 %{_libdir}/%{name}/java.so
546
547 %files libvirt
548 %{_libdir}/%{name}/libvirt.so
549
550 %files memcachec
551 %{_libdir}/%{name}/memcachec.so
552
553 %files mysql
554 %{_libdir}/%{name}/mysql.so
555
556 %files nginx
557 %{_libdir}/%{name}/nginx.so
558
559 %files notify_desktop
560 %{_libdir}/%{name}/notify_desktop.so
561
562 %files notify_email
563 %{_libdir}/%{name}/notify_email.so
564
565 %files nut
566 %{_libdir}/%{name}/nut.so
567
568 %files perl
569 %doc perl-examples/*
570 %{perl_vendorlib}/Collectd.pm
571 %{perl_vendorlib}/Collectd/
572 %{_mandir}/man3/Collectd::Unixsock.3pm.gz
573 %{_mandir}/man5/collectd-perl.5.gz
574 %{_libdir}/%{name}/perl.so
575
576 %files pinba
577 %{_libdir}/%{name}/pinba.so
578
579 %files ping
580 %{_libdir}/%{name}/ping.so
581
582 %files postgresql
583 %{_datarootdir}/collectd/postgresql_default.conf
584 %{_libdir}/%{name}/postgresql.so
585
586 %files python
587 %{_mandir}/man5/collectd-python.5.gz
588 %{_libdir}/%{name}/python.so
589
590 %files rrdtool
591 %{_libdir}/%{name}/rrdtool.so
592
593 %files sensors
594 %{_libdir}/%{name}/sensors.so
595
596 %files snmp
597 %{_mandir}/man5/collectd-snmp.5.gz
598 %{_libdir}/%{name}/snmp.so
599
600 %files varnish
601 %{_libdir}/%{name}/varnish.so
602
603 %files write_http
604 %{_libdir}/%{name}/write_http.so
605
606 %files contrib
607 %doc contrib/
608
609 %changelog
610 * Sat Nov 17 2012 Ruben Kerkhof <ruben@tilaa.nl> 5.1.0-2
611 - Move perl stuff to perl_vendorlib
612 - Replace hardcoded paths with macros
613 - Remove unneccesary Requires
614 - Removed .a and .la files
615 - Some other small cleanups
616
617 * Fri Nov 16 2012 Marc Fournier <marc.fournier@camptocamp.com> 5.1.0-1
618 - New upstream version
619 - Changes to support 5.1.0
620 - Enabled all buildable plugins based on libraries available on EL6 + EPEL
621 - All plugins requiring external libraries are now shipped in seperate
622   packages.
623 - No longer treat Java plugin as an exception, correctly set $JAVA_HOME during
624   the build process + ensure build deps are installed.
625 - Dropped per-plugin configuration files, as they tend to diverge from upstream
626   defaults.
627 - Moved perl stuff to /usr/share/perl5/
628 - Don't alter Interval and ReadThreads by default, let the user change this
629   himself.
630 - Initscript improvements:
631   * checks configuration before (re)starting, based on debian's initscript
632   * use /etc/sysconfig instdead of /etc/default
633   * include optional $ARGS in arguments passed to collectd.
634 - Drop collection.cgi from main package, as it's been obsoleted by collection3
635 - Moved contrib/ to its own package, to avoid cluttering the main package with
636   non-essential stuff.
637 - Replaced BuildPrereq by BuildRequires
638
639 * Tue Jan 03 2011 Monetate <jason.stelzer@monetate.com> 5.0.1
640 - New upstream version
641 - Changes to support 5.0.1
642
643 * Tue Jan 04 2010 Rackspace <stu.hood@rackspace.com> 4.9.0
644 - New upstream version
645 - Changes to support 4.9.0
646 - Added support for Java/GenericJMX plugin
647
648 * Mon Mar 17 2008 RightScale <support@rightscale.com> 4.3.1
649 - New upstream version
650 - Changes to support 4.3.1
651 - Added More Prereqs to support more plugins
652 - Added support for perl plugin
653
654 * Mon Aug 06 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.6
655 - New upstream version
656
657 * Wed Jul 25 2007 Kjell Randa <Kjell.Randa@broadpark.no> 4.0.5
658 - New major releas
659 - Changes to support 4.0.5
660
661 * Wed Jan 11 2007 Iain Lea <iain@bricbrac.de> 3.11.0-0
662 - fixed spec file to build correctly on fedora core
663 - added improved init.d script to work with chkconfig
664 - added %%post and %%postun to call chkconfig automatically
665
666 * Sun Jul 09 2006 Florian octo Forster <octo@verplant.org> 3.10.0-1
667 - New upstream version
668
669 * Tue Jun 25 2006 Florian octo Forster <octo@verplant.org> 3.9.4-1
670 - New upstream version
671
672 * Tue Jun 01 2006 Florian octo Forster <octo@verplant.org> 3.9.3-1
673 - New upstream version
674
675 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.9.2-1
676 - New upstream version
677
678 * Tue May 09 2006 Florian octo Forster <octo@verplant.org> 3.8.5-1
679 - New upstream version
680
681 * Fri Apr 21 2006 Florian octo Forster <octo@verplant.org> 3.9.1-1
682 - New upstream version
683
684 * Fri Apr 14 2006 Florian octo Forster <octo@verplant.org> 3.9.0-1
685 - New upstream version
686 - Added the `apache' package.
687
688 * Thu Mar 14 2006 Florian octo Forster <octo@verplant.org> 3.8.2-1
689 - New upstream version
690
691 * Thu Mar 13 2006 Florian octo Forster <octo@verplant.org> 3.8.1-1
692 - New upstream version
693
694 * Thu Mar 09 2006 Florian octo Forster <octo@verplant.org> 3.8.0-1
695 - New upstream version
696
697 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
698 - Include `tape.so' so the build doesn't terminate because of missing files..
699 - New upstream version
700
701 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
702 - New upstream version
703
704 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
705 - New upstream version
706 - Removed the extra `hddtemp' package
707
708 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
709 - New upstream version
710
711 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
712 - New upstream version
713
714 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
715 - New upstream version
716 - Added config file, `collectd.conf(5)', `df.so'
717 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
718
719 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
720 - New upstream version
721
722 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
723 - New upstream version
724
725 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
726 - New upstream version
727
728 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
729 - New upstream version
730 - Added statement to remove the `*.la' files. This fixes a problem when
731   `Unpackaged files terminate build' is in effect.
732 - Added `processes.so*' to the main package
733
734 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
735 - New upstream version
736 - Added package `collectd-hddtemp'
737
738 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
739 - New upstream version
740 - Split the package into `collectd' and `collectd-sensors'
741
742 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
743 - New upstream version
744
745 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
746 - New upstream version
747
748 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
749 - New upstream version
750
751 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
752 - New upstream version
753
754 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
755 - New upstream version
756
757 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
758 - New upstream version
759
760 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
761 - New upstream version
762
763 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
764 - New upstream version
765
766 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
767 - Built on RedHat 7.3