Build system: Install the config file.
[collection4.git] / src / Makefile.am
index de0cb7e..9b91a91 100644 (file)
@@ -1,8 +1,12 @@
 AUTOMAKE_OPTIONS = foreign no-dependencies
 
+AM_CPPFLAGS = -DPREFIX='"${prefix}"'
+AM_CPPFLAGS += -DCONFIGFILE='"${sysconfdir}/collection.conf"'
+
 if COMPILER_IS_GCC
 AM_CFLAGS = -Wall -Wextra
 endif
+
 AM_YFLAGS = -d
 
 BUILT_SOURCES = parser.h
@@ -15,6 +19,7 @@ collection_fcgi_SOURCES = main.c \
                          action_list_graphs.c action_list_graphs.h \
                          common.c common.h \
                          filesystem.c filesystem.h \
+                         graph_types.h \
                          graph.c graph.h \
                          graph_config.c graph_config.h \
                          graph_def.c graph_def.h \